aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.14/003-ethernet.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 20:12:02 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 20:12:02 +0000
commitdd4ee63fa43cf13190891a5df62676054942b52e (patch)
tree961871e70f77414e4bc647923a07119390b4676e /target/linux/mcs814x/patches-3.14/003-ethernet.patch
parent3b523f6780113b0f55a2362ab093145dfa2a7c75 (diff)
downloadupstream-dd4ee63fa43cf13190891a5df62676054942b52e.tar.gz
upstream-dd4ee63fa43cf13190891a5df62676054942b52e.tar.bz2
upstream-dd4ee63fa43cf13190891a5df62676054942b52e.zip
mcs814x: add 3.14 kernel support
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 43926
Diffstat (limited to 'target/linux/mcs814x/patches-3.14/003-ethernet.patch')
-rw-r--r--target/linux/mcs814x/patches-3.14/003-ethernet.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.14/003-ethernet.patch b/target/linux/mcs814x/patches-3.14/003-ethernet.patch
new file mode 100644
index 0000000000..21598cbcca
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.14/003-ethernet.patch
@@ -0,0 +1,16 @@
+--- a/drivers/net/ethernet/Kconfig
++++ b/drivers/net/ethernet/Kconfig
+@@ -167,4 +167,6 @@ source "drivers/net/ethernet/wiznet/Kcon
+ source "drivers/net/ethernet/xilinx/Kconfig"
+ source "drivers/net/ethernet/xircom/Kconfig"
+
++source "drivers/net/ethernet/mcs8140/Kconfig"
++
+ endif # ETHERNET
+--- a/drivers/net/ethernet/Makefile
++++ b/drivers/net/ethernet/Makefile
+@@ -77,3 +77,4 @@ obj-$(CONFIG_NET_VENDOR_VIA) += via/
+ obj-$(CONFIG_NET_VENDOR_WIZNET) += wiznet/
+ obj-$(CONFIG_NET_VENDOR_XILINX) += xilinx/
+ obj-$(CONFIG_NET_VENDOR_XIRCOM) += xircom/
++obj-$(CONFIG_NUPORT_ETHERNET_DRIVER) += mcs8140/