aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-15 14:38:36 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-15 14:38:36 +0000
commit3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92 (patch)
tree3629c253019aec1a0c90a8c75970c73791f8ed57 /target/linux/mcs814x/image
parent7386b196138dc08b98252374bea53fdddc03445b (diff)
downloadupstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.tar.gz
upstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.tar.bz2
upstream-3b15d86f3c2939b30dd9afb4a5fa8f9f6560ac92.zip
mcs814x: use firmware partition splitter on dLAN USB Extender
to avoid editing the dts every time the kernel size changes. uImage is now bigger than 1MB. Pad uImage to 64k erase block size. Signed-off-by: Günther Kelleter <guenther.kelleter@devolo.de> Backport of r46648 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47194 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 4c8af97d22..74f8ad48af 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -30,7 +30,7 @@ define Image/Build/DTB
endef
define Image/Build/Profile/dLAN_USB_Extender
- dd if=$(KDIR)/uImage-dlan-usb-extender bs=1M conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
+ dd if=$(KDIR)/uImage-dlan-usb-extender bs=64k conv=sync of=$(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cat $(KDIR)/root.$(1) >> $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin
cp $(KDIR)/$(IMG_PREFIX)-dlan-usb-extender-upgrade-$(1).bin $(BIN_DIR)/
endef