aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-06-19 14:48:56 +0000
commitfea5404e8a8b3d0190c8386f190b723477acebd4 (patch)
tree7b34e2be994fc0c2bdd15a6868864b39be34d6bc /target/linux/mcs814x/Makefile
parent208fa63215795719b6875e7f5bc2090400c5ea1e (diff)
downloadupstream-fea5404e8a8b3d0190c8386f190b723477acebd4.tar.gz
upstream-fea5404e8a8b3d0190c8386f190b723477acebd4.tar.bz2
upstream-fea5404e8a8b3d0190c8386f190b723477acebd4.zip
[mcs814x] add Moschip MSC814x support
This target currently only supports Moschip's MCS8140 SoC, but support for other chips in the same family (MCS8142, MCS8144) will be easy to add. Target support is entirely using Device Tree for probing peripherals. Drivers support include: - PCI - USB 1 & 2 - watchdog - random number generator - UART - timer - internal Ethernet PHY - Ethernet MAC core Support for the following boards is included using Device Tree - Devolo dLAN USB Extender - Tigal RBT-832 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32462 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/Makefile')
-rw-r--r--target/linux/mcs814x/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/mcs814x/Makefile b/target/linux/mcs814x/Makefile
new file mode 100644
index 0000000000..018cdb0754
--- /dev/null
+++ b/target/linux/mcs814x/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mcs814x
+BOARDNAME:=Moschip MCS814x
+FEATURES:=pci usb
+CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ kmod-usb-storage kmod-fs-vfat \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
+ kmod-nls-utf8 \
+ kmod-mcs814x-wdt
+
+KERNELNAME:="zImage dtbs"
+
+$(eval $(call BuildTarget))