aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-13 19:19:34 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-13 19:46:45 +0100
commitd2424d4b21c88f1bf262665389d217d3cc8ff416 (patch)
treebfe1e1ecda44fead60553ebec6a5c0642eebabc6 /target/linux/malta
parent3e521fa11227b54d25c93aad335a9c4bd696c09a (diff)
downloadupstream-d2424d4b21c88f1bf262665389d217d3cc8ff416.tar.gz
upstream-d2424d4b21c88f1bf262665389d217d3cc8ff416.tar.bz2
upstream-d2424d4b21c88f1bf262665389d217d3cc8ff416.zip
malta: remove hack to determine entry point
Malta has CONFIG_BOOT_RAW set, so jumping to the load address is valid Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/malta')
-rw-r--r--target/linux/malta/image/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/target/linux/malta/image/Makefile b/target/linux/malta/image/Makefile
index 180e045ec7..31eb7ca0bb 100644
--- a/target/linux/malta/image/Makefile
+++ b/target/linux/malta/image/Makefile
@@ -7,10 +7,6 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define get_kernel_entry
-0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
-endef
-
define CompressLzma
$(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
endef
@@ -21,7 +17,7 @@ endef
define MkuImage
mkimage -A mips -O linux -T kernel -a 0x80100000 -C $(1) $(2) \
- -e $(call get_kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -e 0x80100000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
-d $(3) $(4)
endef