aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/linux-2.6/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-23 21:06:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-23 21:06:51 +0000
commitf70edb670a86a0709ff614adf16011ba9f6684ea (patch)
tree7078983cd632fa349bd542a9015722590df41032 /target/linux/linux-2.6/patches
parent484f442adcbd75e875a18134f1588766035f4d20 (diff)
downloadupstream-f70edb670a86a0709ff614adf16011ba9f6684ea.tar.gz
upstream-f70edb670a86a0709ff614adf16011ba9f6684ea.tar.bz2
upstream-f70edb670a86a0709ff614adf16011ba9f6684ea.zip
add -funit-at-a-time in trunk/ as well
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/linux-2.6/patches')
-rw-r--r--target/linux/linux-2.6/patches/generic/004-extra_optimization.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/linux-2.6/patches/generic/004-extra_optimization.patch b/target/linux/linux-2.6/patches/generic/004-extra_optimization.patch
new file mode 100644
index 0000000000..805d2f0ea9
--- /dev/null
+++ b/target/linux/linux-2.6/patches/generic/004-extra_optimization.patch
@@ -0,0 +1,12 @@
+--- linux-2.6.12.5/Makefile.old 2005-10-23 22:56:29.017270000 +0200
++++ linux-2.6.12.5/Makefile 2005-10-23 22:57:23.226138500 +0200
+@@ -533,6 +533,9 @@
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+