aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-10 00:20:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-10 00:20:22 +0000
commit4e87f8de270ec6c7af4e13c3c26c598e6925caa6 (patch)
tree2209af2478fd3c91b486f544a346e28166ee618a /target/linux/linux-2.4/Makefile
parent2111fcc44fc85bc9114c17be86581402e40548f8 (diff)
downloadupstream-4e87f8de270ec6c7af4e13c3c26c598e6925caa6.tar.gz
upstream-4e87f8de270ec6c7af4e13c3c26c598e6925caa6.tar.bz2
upstream-4e87f8de270ec6c7af4e13c3c26c598e6925caa6.zip
add ar7 adsl driver support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/linux-2.4/Makefile')
-rw-r--r--target/linux/linux-2.4/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index de0f815cad..31a3775767 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -53,6 +53,16 @@ include ./broadcom.mk
endif
+$(eval $(call KMOD_template,SANGAM_ATM,sangam-atm,\
+ $(MODULES_DIR)/kernel/drivers/atm/tiatm.o \
+,CONFIG_MIPS_SANGAM_ATM))
+$(eval $(call KMOD_template,ATM,atm,\
+ $(MODULES_DIR)/kernel/net/atm/atm.o \
+ $(MODULES_DIR)/kernel/net/atm/br2684.o \
+,CONFIG_ATM))
+$(eval $(call KMOD_template,PPPOATM,pppoatm,\
+ $(MODULES_DIR)/kernel/net/atm/pppoatm.o \
+,CONFIG_PPPOATM))
$(eval $(call KMOD_template,CPMAC,cpmac,\
$(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
,CONFIG_MIPS_AVALANCHE_CPMAC))