aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-09 15:05:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-09 15:05:01 +0000
commit30c5c6daec4d417ca30f9f25592928d9078796f5 (patch)
tree6ef5665822c95a1f36a46534ef92da7677fb7c1a /target/linux/linux-2.4/Makefile
parentd6bee076c7235064beb1ca45043c9e12017e1a73 (diff)
downloadupstream-30c5c6daec4d417ca30f9f25592928d9078796f5.tar.gz
upstream-30c5c6daec4d417ca30f9f25592928d9078796f5.tar.bz2
upstream-30c5c6daec4d417ca30f9f25592928d9078796f5.zip
some additions to the ar7 system code, added cpmac network driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1383 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/linux-2.4/Makefile')
-rw-r--r--target/linux/linux-2.4/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index 6993c3de73..de0f815cad 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -52,6 +52,10 @@ ifeq ($(BOARD),brcm)
include ./broadcom.mk
endif
+
+$(eval $(call KMOD_template,CPMAC,cpmac,\
+ $(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
+,CONFIG_MIPS_AVALANCHE_CPMAC))
$(eval $(call KMOD_template,USB_ACM,usb-acm,\
$(MODULES_DIR)/kernel/drivers/usb/acm.o \
,CONFIG_USB_ACM))