aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-06-29 11:19:07 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit806624add541bd828516a58aab20ae19ae9e431f (patch)
treee5bb450e4b18defde11492f2a3578f1ad04e8163 /target/linux/layerscape
parent4c89f2fcf8f6579257342cfca47293c0ac16fe86 (diff)
downloadupstream-806624add541bd828516a58aab20ae19ae9e431f.tar.gz
upstream-806624add541bd828516a58aab20ae19ae9e431f.tar.bz2
upstream-806624add541bd828516a58aab20ae19ae9e431f.zip
layerscape: rename subtargets and update makefile files
Rename subtargets 32b/64b with armv8_32b/armv8_64b which are more proper, and update makefile files. There also will be other subtargets added in the future, like armv7. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape')
l---------target/linux/layerscape/32b/profiles/00-default.mk1
-rw-r--r--target/linux/layerscape/Makefile8
-rw-r--r--target/linux/layerscape/armv8_32b/config-default (renamed from target/linux/layerscape/32b/config-default)0
-rw-r--r--target/linux/layerscape/armv8_32b/profiles/00-default.mk (renamed from target/linux/layerscape/64b/profiles/00-default.mk)0
-rw-r--r--target/linux/layerscape/armv8_32b/target.mk (renamed from target/linux/layerscape/32b/target.mk)4
-rw-r--r--target/linux/layerscape/armv8_64b/config-default (renamed from target/linux/layerscape/64b/config-default)0
-rw-r--r--target/linux/layerscape/armv8_64b/profiles/00-default.mk18
-rw-r--r--target/linux/layerscape/armv8_64b/target.mk (renamed from target/linux/layerscape/64b/target.mk)5
-rw-r--r--target/linux/layerscape/image/Makefile29
9 files changed, 28 insertions, 37 deletions
diff --git a/target/linux/layerscape/32b/profiles/00-default.mk b/target/linux/layerscape/32b/profiles/00-default.mk
deleted file mode 120000
index 7b77749858..0000000000
--- a/target/linux/layerscape/32b/profiles/00-default.mk
+++ /dev/null
@@ -1 +0,0 @@
-../../64b/profiles/00-default.mk \ No newline at end of file
diff --git a/target/linux/layerscape/Makefile b/target/linux/layerscape/Makefile
index 3def184b94..c2d3cc07af 100644
--- a/target/linux/layerscape/Makefile
+++ b/target/linux/layerscape/Makefile
@@ -12,15 +12,15 @@ DEVICE_TYPE:=developerboard
KERNEL_PATCHVER:=4.4
KERNELNAME:=Image dtbs
FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
+SUBTARGETS:=armv8_64b armv8_32b
MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
- Build firmware images for $(BOARDNAME) SoC devices.
+ Build firmware images for NXP Layerscape based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
$(eval $(call BuildTarget))
diff --git a/target/linux/layerscape/32b/config-default b/target/linux/layerscape/armv8_32b/config-default
index 7aa0dd5c53..7aa0dd5c53 100644
--- a/target/linux/layerscape/32b/config-default
+++ b/target/linux/layerscape/armv8_32b/config-default
diff --git a/target/linux/layerscape/64b/profiles/00-default.mk b/target/linux/layerscape/armv8_32b/profiles/00-default.mk
index fc1231dc7a..fc1231dc7a 100644
--- a/target/linux/layerscape/64b/profiles/00-default.mk
+++ b/target/linux/layerscape/armv8_32b/profiles/00-default.mk
diff --git a/target/linux/layerscape/32b/target.mk b/target/linux/layerscape/armv8_32b/target.mk
index 13eae24555..ed89d8e4ec 100644
--- a/target/linux/layerscape/32b/target.mk
+++ b/target/linux/layerscape/armv8_32b/target.mk
@@ -6,9 +6,9 @@
#
ARCH:=arm
-BOARDNAME:=layerscape 32b boards
+BOARDNAME:=ARMv8 32-bit based boards
CPU_TYPE:=cortex-a9
define Target/Description
- Build firmware images for $(BOARDNAME) SoC devices.
+ Build firmware images for NXP Layerscape ARMv8 32-bit based boards.
endef
diff --git a/target/linux/layerscape/64b/config-default b/target/linux/layerscape/armv8_64b/config-default
index 960b0770e4..960b0770e4 100644
--- a/target/linux/layerscape/64b/config-default
+++ b/target/linux/layerscape/armv8_64b/config-default
diff --git a/target/linux/layerscape/armv8_64b/profiles/00-default.mk b/target/linux/layerscape/armv8_64b/profiles/00-default.mk
new file mode 100644
index 0000000000..fc1231dc7a
--- /dev/null
+++ b/target/linux/layerscape/armv8_64b/profiles/00-default.mk
@@ -0,0 +1,18 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+
+DEFAULT_PACKAGES+= \
+ rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb \
+ fman-layerscape-ls1043ardb \
+ rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb \
+ fman-layerscape-ls1046ardb \
+ rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
+ kmod-ppfe ppfe-ls1012ardb
+
+$(eval $(call Profile,Default))
diff --git a/target/linux/layerscape/64b/target.mk b/target/linux/layerscape/armv8_64b/target.mk
index 98aa8be9c4..f1db72d973 100644
--- a/target/linux/layerscape/64b/target.mk
+++ b/target/linux/layerscape/armv8_64b/target.mk
@@ -6,9 +6,8 @@
#
ARCH:=aarch64
-BOARDNAME:=layerscape 64b boards
+BOARDNAME:=ARMv8 64-bit based boards
define Target/Description
- Build firmware images for $(BOARDNAME) SoC devices.
+ Build firmware images for NXP Layerscape ARMv8 64-bit based boards.
endef
-
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 107a3e6eed..9d5b6e4543 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -37,11 +37,11 @@ define Device/Default
DEVICE_DTS :=
IMAGES = firmware.bin
-ifeq ($(SUBTARGET),64b)
+ifeq ($(SUBTARGET),armv8_64b)
KERNEL_LOADADDR = 0x80080000
KERNEL_ENTRY_POINT = 0x80080000
endif
-ifeq ($(SUBTARGET),32b)
+ifeq ($(SUBTARGET),armv8_32b)
KERNEL_LOADADDR = 0x80008000
KERNEL_ENTRY_POINT = 0x80008000
endif
@@ -50,12 +50,7 @@ endef
define Device/ls1043ardb
DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb fman-layerscape-ls1043ardb
-ifeq ($(SUBTARGET),64b)
- DEVICE_DTS = freescale/fsl-ls1043a-rdb
-endif
-ifeq ($(SUBTARGET),32b)
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb
-endif
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
append-ls-fman $(1) | pad-to 4M | append-ls-dtb $$(DEVICE_DTS) | pad-to 5M | \
append-kernel | pad-to 10M | append-rootfs | pad-rootfs | check-size 67108865
@@ -65,12 +60,7 @@ TARGET_DEVICES += ls1043ardb
define Device/ls1046ardb
DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb fman-layerscape-ls1046ardb
-ifeq ($(SUBTARGET),64b)
- DEVICE_DTS = freescale/fsl-ls1046a-rdb
-endif
-ifeq ($(SUBTARGET),32b)
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb
-endif
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
append-ls-fman $(1) | pad-to 4M | append-ls-dtb $$(DEVICE_DTS) | pad-to 5M | \
append-kernel | pad-to 10M | append-ls-rootfs-ext4 $(1) 22M | check-size 33554433
@@ -80,12 +70,7 @@ TARGET_DEVICES += ls1046ardb
define Device/ls1012ardb
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb kmod-ppfe ppfe-ls1012ardb
-ifeq ($(SUBTARGET),64b)
- DEVICE_DTS = freescale/fsl-ls1012a-rdb
-endif
-ifeq ($(SUBTARGET),32b)
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
-endif
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 4M | append-kernel | pad-to 9M | \
append-ls-rootfs-ext4 $(1) 23M | check-size 33554433
@@ -95,12 +80,7 @@ TARGET_DEVICES += ls1012ardb
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb mc-binary-ls1088ardb
-ifeq ($(SUBTARGET),64b)
- DEVICE_DTS = freescale/fsl-ls1088a-rdb
-endif
-ifeq ($(SUBTARGET),32b)
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
-endif
IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | append-kernel | pad-to 6M | \
append-ls-rootfs-ext4 $(1) 17M | check-size 24117249
endef
@@ -109,12 +89,7 @@ TARGET_DEVICES += ls1088ardb
define Device/ls2088ardb
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb mc-binary-ls2088ardb
-ifeq ($(SUBTARGET),64b)
- DEVICE_DTS = freescale/fsl-ls2088a-rdb
-endif
-ifeq ($(SUBTARGET),32b)
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
-endif
IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | append-kernel | pad-to 6M | \
append-rootfs | pad-rootfs | check-size 24117249
endef