aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-01-06 13:53:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-01-06 19:38:55 +0100
commit88ca6390eab24efda3f6333453cd645b5e20e400 (patch)
treeaca0017be6abf1534934ec15cac1da4fd30c66f7 /target/linux/layerscape
parentb9857b21c27c3ba98a400cd797c540baa9f40be1 (diff)
downloadupstream-88ca6390eab24efda3f6333453cd645b5e20e400.tar.gz
upstream-88ca6390eab24efda3f6333453cd645b5e20e400.tar.bz2
upstream-88ca6390eab24efda3f6333453cd645b5e20e400.zip
kernel: bump to 4.4.40
Refresh patches on all 4.4 supported platforms. Compile & run tested: lantiq/xrx200 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/layerscape')
-rw-r--r--target/linux/layerscape/patches-4.4/0238-arm64-disable-CONFIG_EEPROM_AT24-for-freescale.confi.patch5
-rw-r--r--target/linux/layerscape/patches-4.4/1239-mtd-extend-physmap_of-to-let-the-device-tree-specify.patch9
-rw-r--r--target/linux/layerscape/patches-4.4/3226-mtd-spi-nor-fsl-quadspi-Enable-fast-read-for-LS1088A.patch1
-rw-r--r--target/linux/layerscape/patches-4.4/3227-ls2088a-dts-add-ls2088a-dts.patch16
-rw-r--r--target/linux/layerscape/patches-4.4/3228-ls2088a-add-ls2088a-its.patch9
-rw-r--r--target/linux/layerscape/patches-4.4/4234-fsl-ifc-fix-compilation-error-when-COMPAT-not-enable.patch5
-rw-r--r--target/linux/layerscape/patches-4.4/8138-pci-layerscape-add-MSI-interrupt-support.patch2
-rw-r--r--target/linux/layerscape/patches-4.4/8229-drivers-clk-qoriq-Add-ls2088a-key-to-chipinfo-table.patch7
-rw-r--r--target/linux/layerscape/patches-4.4/8230-layerscape-pci-fix-linkup-issue.patch17
-rw-r--r--target/linux/layerscape/patches-4.4/8231-driver-clk-qoriq-Add-ls2088a-clk-support.patch7
-rw-r--r--target/linux/layerscape/patches-4.4/8233-i2c-pca954x-Add-option-to-skip-disabling-PCA954x-Mux.patch13
-rw-r--r--target/linux/layerscape/patches-4.4/8235-pci-layerscape-fix-pci-lut-offset-issue.patch13
-rw-r--r--target/linux/layerscape/patches-4.4/8236-clk-add-API-of-clks.patch17
-rw-r--r--target/linux/layerscape/patches-4.4/8237-pcie-ls208x-use-unified-compatible-fsl-ls2080a-pcie-.patch19
14 files changed, 30 insertions, 110 deletions
diff --git a/target/linux/layerscape/patches-4.4/0238-arm64-disable-CONFIG_EEPROM_AT24-for-freescale.confi.patch b/target/linux/layerscape/patches-4.4/0238-arm64-disable-CONFIG_EEPROM_AT24-for-freescale.confi.patch
index d8f6c2b7df..a16524a671 100644
--- a/target/linux/layerscape/patches-4.4/0238-arm64-disable-CONFIG_EEPROM_AT24-for-freescale.confi.patch
+++ b/target/linux/layerscape/patches-4.4/0238-arm64-disable-CONFIG_EEPROM_AT24-for-freescale.confi.patch
@@ -12,8 +12,6 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
arch/arm64/configs/freescale.config | 1 -
1 file changed, 1 deletion(-)
-diff --git a/arch/arm64/configs/freescale.config b/arch/arm64/configs/freescale.config
-index a31951c..5447d7a 100644
--- a/arch/arm64/configs/freescale.config
+++ b/arch/arm64/configs/freescale.config
@@ -121,7 +121,6 @@ CONFIG_IMX2_WDT=y
@@ -24,6 +22,3 @@ index a31951c..5447d7a 100644
# lpuart
CONFIG_SERIAL_FSL_LPUART=y
CONFIG_SERIAL_FSL_LPUART_CONSOLE=y
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/1239-mtd-extend-physmap_of-to-let-the-device-tree-specify.patch b/target/linux/layerscape/patches-4.4/1239-mtd-extend-physmap_of-to-let-the-device-tree-specify.patch
index 8254490bb0..0fdbb7ea38 100644
--- a/target/linux/layerscape/patches-4.4/1239-mtd-extend-physmap_of-to-let-the-device-tree-specify.patch
+++ b/target/linux/layerscape/patches-4.4/1239-mtd-extend-physmap_of-to-let-the-device-tree-specify.patch
@@ -17,11 +17,9 @@ Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
drivers/mtd/maps/physmap_of.c | 46 ++++++++++++++++++++++++++++++++++++++++-
1 file changed, 45 insertions(+), 1 deletion(-)
-diff --git a/drivers/mtd/maps/physmap_of.c b/drivers/mtd/maps/physmap_of.c
-index fef1d1b..e46b4e9 100644
--- a/drivers/mtd/maps/physmap_of.c
+++ b/drivers/mtd/maps/physmap_of.c
-@@ -112,9 +112,47 @@ static struct mtd_info *obsolete_probe(struct platform_device *dev,
+@@ -112,9 +112,47 @@ static struct mtd_info *obsolete_probe(s
static const char * const part_probe_types_def[] = {
"cmdlinepart", "RedBoot", "ofpart", "ofoldpart", NULL };
@@ -69,7 +67,7 @@ index fef1d1b..e46b4e9 100644
const struct of_device_id *match;
struct device_node *dp = dev->dev.of_node;
struct resource res;
-@@ -273,8 +311,14 @@ static int of_flash_probe(struct platform_device *dev)
+@@ -273,8 +311,14 @@ static int of_flash_probe(struct platfor
goto err_out;
ppdata.of_node = dp;
@@ -85,6 +83,3 @@ index fef1d1b..e46b4e9 100644
kfree(mtd_list);
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/3226-mtd-spi-nor-fsl-quadspi-Enable-fast-read-for-LS1088A.patch b/target/linux/layerscape/patches-4.4/3226-mtd-spi-nor-fsl-quadspi-Enable-fast-read-for-LS1088A.patch
index 29f887a84e..fa2a1d3089 100644
--- a/target/linux/layerscape/patches-4.4/3226-mtd-spi-nor-fsl-quadspi-Enable-fast-read-for-LS1088A.patch
+++ b/target/linux/layerscape/patches-4.4/3226-mtd-spi-nor-fsl-quadspi-Enable-fast-read-for-LS1088A.patch
@@ -41,4 +41,3 @@ Integrated-by: Jiang Yutang <yutang.jiang@nxp.com>
};
pcie@3400000 {
-
diff --git a/target/linux/layerscape/patches-4.4/3227-ls2088a-dts-add-ls2088a-dts.patch b/target/linux/layerscape/patches-4.4/3227-ls2088a-dts-add-ls2088a-dts.patch
index 91de6f4019..b3b6991dd7 100644
--- a/target/linux/layerscape/patches-4.4/3227-ls2088a-dts-add-ls2088a-dts.patch
+++ b/target/linux/layerscape/patches-4.4/3227-ls2088a-dts-add-ls2088a-dts.patch
@@ -14,11 +14,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
create mode 100644 arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
-diff --git a/arch/arm64/boot/dts/freescale/Makefile b/arch/arm64/boot/dts/freescale/Makefile
-index b599645..e6c2a9f 100644
--- a/arch/arm64/boot/dts/freescale/Makefile
+++ b/arch/arm64/boot/dts/freescale/Makefile
-@@ -6,6 +6,8 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-rdb.dtb
+@@ -6,6 +6,8 @@ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1046a-rdb.dtb
dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1088a-rdb.dtb
@@ -27,9 +25,6 @@ index b599645..e6c2a9f 100644
always := $(dtb-y)
subdir-y := $(dts-dirs)
-diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts b/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts
-new file mode 100644
-index 0000000..04d3726
--- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-qds.dts
@@ -0,0 +1,241 @@
@@ -274,9 +269,6 @@ index 0000000..04d3726
+&dpmac12 {
+ phy-handle = <&mdio0_phy15>;
+};
-diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts b/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
-new file mode 100644
-index 0000000..ce553fb
--- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a-rdb.dts
@@ -0,0 +1,207 @@
@@ -487,9 +479,6 @@ index 0000000..ce553fb
+&dpmac8 {
+ phy-handle = <&mdio2_phy4>;
+};
-diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
-new file mode 100644
-index 0000000..bd69942
--- /dev/null
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
@@ -0,0 +1,854 @@
@@ -1347,6 +1336,3 @@ index 0000000..bd69942
+ /* DRAM space 1 - 2 GB DRAM */
+ };
+};
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/3228-ls2088a-add-ls2088a-its.patch b/target/linux/layerscape/patches-4.4/3228-ls2088a-add-ls2088a-its.patch
index 7fb9b17d43..7aa6382575 100644
--- a/target/linux/layerscape/patches-4.4/3228-ls2088a-add-ls2088a-its.patch
+++ b/target/linux/layerscape/patches-4.4/3228-ls2088a-add-ls2088a-its.patch
@@ -11,9 +11,6 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
create mode 100644 kernel2088a-qds.its
create mode 100644 kernel2088a-rdb.its
-diff --git a/kernel2088a-qds.its b/kernel2088a-qds.its
-new file mode 100644
-index 0000000..4732954
--- /dev/null
+++ b/kernel2088a-qds.its
@@ -0,0 +1,55 @@
@@ -72,9 +69,6 @@ index 0000000..4732954
+ };
+ };
+};
-diff --git a/kernel2088a-rdb.its b/kernel2088a-rdb.its
-new file mode 100644
-index 0000000..151241f
--- /dev/null
+++ b/kernel2088a-rdb.its
@@ -0,0 +1,55 @@
@@ -133,6 +127,3 @@ index 0000000..151241f
+ };
+ };
+};
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/4234-fsl-ifc-fix-compilation-error-when-COMPAT-not-enable.patch b/target/linux/layerscape/patches-4.4/4234-fsl-ifc-fix-compilation-error-when-COMPAT-not-enable.patch
index f3079a51d6..2097be0c7f 100644
--- a/target/linux/layerscape/patches-4.4/4234-fsl-ifc-fix-compilation-error-when-COMPAT-not-enable.patch
+++ b/target/linux/layerscape/patches-4.4/4234-fsl-ifc-fix-compilation-error-when-COMPAT-not-enable.patch
@@ -17,8 +17,6 @@ Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
drivers/memory/fsl_ifc.c | 1 +
1 file changed, 1 insertion(+)
-diff --git a/drivers/memory/fsl_ifc.c b/drivers/memory/fsl_ifc.c
-index 03584dc..32c7752 100644
--- a/drivers/memory/fsl_ifc.c
+++ b/drivers/memory/fsl_ifc.c
@@ -35,6 +35,7 @@
@@ -29,6 +27,3 @@ index 03584dc..32c7752 100644
struct fsl_ifc_ctrl *fsl_ifc_ctrl_dev;
EXPORT_SYMBOL(fsl_ifc_ctrl_dev);
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8138-pci-layerscape-add-MSI-interrupt-support.patch b/target/linux/layerscape/patches-4.4/8138-pci-layerscape-add-MSI-interrupt-support.patch
index 96c69f3832..0db0a6b6d3 100644
--- a/target/linux/layerscape/patches-4.4/8138-pci-layerscape-add-MSI-interrupt-support.patch
+++ b/target/linux/layerscape/patches-4.4/8138-pci-layerscape-add-MSI-interrupt-support.patch
@@ -129,7 +129,7 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
static bool ls_pcie_is_bridge(struct ls_pcie *pcie)
{
u32 header_type;
-@@ -276,10 +301,28 @@ static int __init ls_pcie_probe(struct p
+@@ -284,10 +309,28 @@ static int __init ls_pcie_probe(struct p
pcie->drvdata = match->data;
pcie->lut = pcie->dbi + pcie->drvdata->lut_offset;
diff --git a/target/linux/layerscape/patches-4.4/8229-drivers-clk-qoriq-Add-ls2088a-key-to-chipinfo-table.patch b/target/linux/layerscape/patches-4.4/8229-drivers-clk-qoriq-Add-ls2088a-key-to-chipinfo-table.patch
index 5c1fcd010b..efc6467b09 100644
--- a/target/linux/layerscape/patches-4.4/8229-drivers-clk-qoriq-Add-ls2088a-key-to-chipinfo-table.patch
+++ b/target/linux/layerscape/patches-4.4/8229-drivers-clk-qoriq-Add-ls2088a-key-to-chipinfo-table.patch
@@ -8,11 +8,9 @@ Subject: [PATCH 229/238] drivers: clk: qoriq: Add ls2088a key to chipinfo
drivers/clk/clk-qoriq.c | 11 +++++++++++
1 file changed, 11 insertions(+)
-diff --git a/drivers/clk/clk-qoriq.c b/drivers/clk/clk-qoriq.c
-index 164ac41..6185d6a 100644
--- a/drivers/clk/clk-qoriq.c
+++ b/drivers/clk/clk-qoriq.c
-@@ -559,6 +559,17 @@ static const struct clockgen_chipinfo chipinfo[] = {
+@@ -559,6 +559,17 @@ static const struct clockgen_chipinfo ch
.flags = CG_VER3 | CG_LITTLE_ENDIAN,
},
{
@@ -30,6 +28,3 @@ index 164ac41..6185d6a 100644
.compat = "fsl,p2041-clockgen",
.guts_compat = "fsl,qoriq-device-config-1.0",
.init_periph = p2041_init_periph,
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8230-layerscape-pci-fix-linkup-issue.patch b/target/linux/layerscape/patches-4.4/8230-layerscape-pci-fix-linkup-issue.patch
index 0feb800367..f28776cba1 100644
--- a/target/linux/layerscape/patches-4.4/8230-layerscape-pci-fix-linkup-issue.patch
+++ b/target/linux/layerscape/patches-4.4/8230-layerscape-pci-fix-linkup-issue.patch
@@ -12,31 +12,26 @@ Integrated-by: Zhao Qiang <qiang.zhao@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-)
-diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
-index 00feabf..f85ebcf 100644
--- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c
-@@ -158,11 +158,16 @@ static void ls1021_pcie_host_init(struct pcie_port *pp)
+@@ -158,11 +158,16 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp)
{
struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state;
+ u32 state, offset;
-+
-+ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
-+ offset = 0x407fc;
-+ else
-+ offset = PCIE_LUT_DBG;
- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
- pcie->drvdata->ltssm_shift) &
- LTSSM_STATE_MASK;
++ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
++ offset = 0x407fc;
++ else
++ offset = PCIE_LUT_DBG;
++
+ state = (ioread32(pcie->lut + offset) >>
+ pcie->drvdata->ltssm_shift) &
+ LTSSM_STATE_MASK;
if (state < LTSSM_PCIE_L0)
return 0;
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8231-driver-clk-qoriq-Add-ls2088a-clk-support.patch b/target/linux/layerscape/patches-4.4/8231-driver-clk-qoriq-Add-ls2088a-clk-support.patch
index e98e5022ab..6c95cd0250 100644
--- a/target/linux/layerscape/patches-4.4/8231-driver-clk-qoriq-Add-ls2088a-clk-support.patch
+++ b/target/linux/layerscape/patches-4.4/8231-driver-clk-qoriq-Add-ls2088a-clk-support.patch
@@ -8,11 +8,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>wq
drivers/clk/clk-qoriq.c | 1 +
1 file changed, 1 insertion(+)
-diff --git a/drivers/clk/clk-qoriq.c b/drivers/clk/clk-qoriq.c
-index 6185d6a..efaa9c1 100644
--- a/drivers/clk/clk-qoriq.c
+++ b/drivers/clk/clk-qoriq.c
-@@ -1339,6 +1339,7 @@ CLK_OF_DECLARE(qoriq_clockgen_ls1043a, "fsl,ls1043a-clockgen", clockgen_init);
+@@ -1346,6 +1346,7 @@ CLK_OF_DECLARE(qoriq_clockgen_ls1043a, "
CLK_OF_DECLARE(qoriq_clockgen_ls1046a, "fsl,ls1046a-clockgen", clockgen_init);
CLK_OF_DECLARE(qoriq_clockgen_ls2080a, "fsl,ls2080a-clockgen", clockgen_init);
CLK_OF_DECLARE(qoriq_clockgen_ls1012a, "fsl,ls1012a-clockgen", clockgen_init);
@@ -20,6 +18,3 @@ index 6185d6a..efaa9c1 100644
/* Legacy nodes */
CLK_OF_DECLARE(qoriq_sysclk_1, "fsl,qoriq-sysclk-1.0", sysclk_init);
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8233-i2c-pca954x-Add-option-to-skip-disabling-PCA954x-Mux.patch b/target/linux/layerscape/patches-4.4/8233-i2c-pca954x-Add-option-to-skip-disabling-PCA954x-Mux.patch
index 0967aeb698..3cb39764fd 100644
--- a/target/linux/layerscape/patches-4.4/8233-i2c-pca954x-Add-option-to-skip-disabling-PCA954x-Mux.patch
+++ b/target/linux/layerscape/patches-4.4/8233-i2c-pca954x-Add-option-to-skip-disabling-PCA954x-Mux.patch
@@ -21,8 +21,6 @@ Signed-off-by: Priyanka Jain <Priyanka.Jain@freescale.com>
drivers/i2c/muxes/i2c-mux-pca954x.c | 38 +++++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)
-diff --git a/drivers/i2c/muxes/i2c-mux-pca954x.c b/drivers/i2c/muxes/i2c-mux-pca954x.c
-index acfcef3..386f86f 100644
--- a/drivers/i2c/muxes/i2c-mux-pca954x.c
+++ b/drivers/i2c/muxes/i2c-mux-pca954x.c
@@ -63,6 +63,7 @@ struct pca954x {
@@ -33,7 +31,7 @@ index acfcef3..386f86f 100644
};
struct chip_desc {
-@@ -174,6 +175,13 @@ static int pca954x_deselect_mux(struct i2c_adapter *adap,
+@@ -174,6 +175,13 @@ static int pca954x_deselect_mux(struct i
{
struct pca954x *data = i2c_get_clientdata(client);
@@ -47,7 +45,7 @@ index acfcef3..386f86f 100644
/* Deselect active channel */
data->last_chan = 0;
return pca954x_reg_write(adap, client, data->last_chan);
-@@ -201,6 +209,23 @@ static int pca954x_probe(struct i2c_client *client,
+@@ -201,6 +209,23 @@ static int pca954x_probe(struct i2c_clie
if (!data)
return -ENOMEM;
@@ -71,7 +69,7 @@ index acfcef3..386f86f 100644
i2c_set_clientdata(client, data);
/* Get the mux out of reset if a reset GPIO is specified. */
-@@ -212,13 +237,19 @@ static int pca954x_probe(struct i2c_client *client,
+@@ -212,13 +237,19 @@ static int pca954x_probe(struct i2c_clie
* that the mux is in fact present. This also
* initializes the mux to disconnected state.
*/
@@ -91,7 +89,7 @@ index acfcef3..386f86f 100644
idle_disconnect_dt = of_node &&
of_property_read_bool(of_node, "i2c-mux-idle-disconnect");
-@@ -289,6 +320,13 @@ static int pca954x_resume(struct device *dev)
+@@ -289,6 +320,13 @@ static int pca954x_resume(struct device
struct i2c_client *client = to_i2c_client(dev);
struct pca954x *data = i2c_get_clientdata(client);
@@ -105,6 +103,3 @@ index acfcef3..386f86f 100644
data->last_chan = 0;
return i2c_smbus_write_byte(client, 0);
}
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8235-pci-layerscape-fix-pci-lut-offset-issue.patch b/target/linux/layerscape/patches-4.4/8235-pci-layerscape-fix-pci-lut-offset-issue.patch
index be91046ac1..def79412d7 100644
--- a/target/linux/layerscape/patches-4.4/8235-pci-layerscape-fix-pci-lut-offset-issue.patch
+++ b/target/linux/layerscape/patches-4.4/8235-pci-layerscape-fix-pci-lut-offset-issue.patch
@@ -8,22 +8,20 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)
-diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
-index f85ebcf..00feabf 100644
--- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c
-@@ -158,16 +158,11 @@ static void ls1021_pcie_host_init(struct pcie_port *pp)
+@@ -158,16 +158,11 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp)
{
struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state, offset;
--
++ u32 state;
+
- if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
- offset = 0x407fc;
- else
- offset = PCIE_LUT_DBG;
-+ u32 state;
-
+-
- state = (ioread32(pcie->lut + offset) >>
- pcie->drvdata->ltssm_shift) &
- LTSSM_STATE_MASK;
@@ -33,6 +31,3 @@ index f85ebcf..00feabf 100644
if (state < LTSSM_PCIE_L0)
return 0;
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8236-clk-add-API-of-clks.patch b/target/linux/layerscape/patches-4.4/8236-clk-add-API-of-clks.patch
index f5947f7e06..ce8b518303 100644
--- a/target/linux/layerscape/patches-4.4/8236-clk-add-API-of-clks.patch
+++ b/target/linux/layerscape/patches-4.4/8236-clk-add-API-of-clks.patch
@@ -10,11 +10,9 @@ Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
include/linux/clk.h | 9 +++++++++
3 files changed, 29 insertions(+)
-diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c
-index f13c3f4..0f6bcf5 100644
--- a/drivers/clk/clk.c
+++ b/drivers/clk/clk.c
-@@ -359,6 +359,19 @@ static struct clk_core *clk_core_get_parent_by_index(struct clk_core *core,
+@@ -359,6 +359,19 @@ static struct clk_core *clk_core_get_par
return core->parents[index];
}
@@ -34,7 +32,7 @@ index f13c3f4..0f6bcf5 100644
struct clk_hw *
clk_hw_get_parent_by_index(const struct clk_hw *hw, unsigned int index)
{
-@@ -2033,6 +2046,12 @@ static const struct file_operations clk_summary_fops = {
+@@ -2033,6 +2046,12 @@ static const struct file_operations clk_
.release = single_release,
};
@@ -47,11 +45,9 @@ index f13c3f4..0f6bcf5 100644
static void clk_dump_one(struct seq_file *s, struct clk_core *c, int level)
{
if (!c)
-diff --git a/include/linux/clk-provider.h b/include/linux/clk-provider.h
-index 7cd0171..77dfd61 100644
--- a/include/linux/clk-provider.h
+++ b/include/linux/clk-provider.h
-@@ -650,6 +650,7 @@ unsigned int clk_hw_get_num_parents(const struct clk_hw *hw);
+@@ -656,6 +656,7 @@ unsigned int clk_hw_get_num_parents(cons
struct clk_hw *clk_hw_get_parent(const struct clk_hw *hw);
struct clk_hw *clk_hw_get_parent_by_index(const struct clk_hw *hw,
unsigned int index);
@@ -59,11 +55,9 @@ index 7cd0171..77dfd61 100644
unsigned int __clk_get_enable_count(struct clk *clk);
unsigned long clk_hw_get_rate(const struct clk_hw *hw);
unsigned long __clk_get_flags(struct clk *clk);
-diff --git a/include/linux/clk.h b/include/linux/clk.h
-index 0df4a51..1df90e3 100644
--- a/include/linux/clk.h
+++ b/include/linux/clk.h
-@@ -392,6 +392,15 @@ int clk_set_parent(struct clk *clk, struct clk *parent);
+@@ -392,6 +392,15 @@ int clk_set_parent(struct clk *clk, stru
struct clk *clk_get_parent(struct clk *clk);
/**
@@ -79,6 +73,3 @@ index 0df4a51..1df90e3 100644
* clk_get_sys - get a clock based upon the device name
* @dev_id: device name
* @con_id: connection ID
---
-1.7.9.5
-
diff --git a/target/linux/layerscape/patches-4.4/8237-pcie-ls208x-use-unified-compatible-fsl-ls2080a-pcie-.patch b/target/linux/layerscape/patches-4.4/8237-pcie-ls208x-use-unified-compatible-fsl-ls2080a-pcie-.patch
index 08e1ecba9a..6162e2b257 100644
--- a/target/linux/layerscape/patches-4.4/8237-pcie-ls208x-use-unified-compatible-fsl-ls2080a-pcie-.patch
+++ b/target/linux/layerscape/patches-4.4/8237-pcie-ls208x-use-unified-compatible-fsl-ls2080a-pcie-.patch
@@ -15,8 +15,6 @@ Signed-off-by: Shengzhou Liu <Shengzhou.Liu@nxp.com>
drivers/pci/host/pci-layerscape.c | 13 ++++++++-----
2 files changed, 12 insertions(+), 13 deletions(-)
-diff --git a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
-index bd69942..07c917b 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls2088a.dtsi
@@ -513,8 +513,7 @@
@@ -59,28 +57,26 @@ index bd69942..07c917b 100644
reg = <0x00 0x03700000 0x0 0x00100000 /* controller registers */
0x38 0x00000000 0x0 0x00002000>; /* configuration space */
reg-names = "regs", "config";
-diff --git a/drivers/pci/host/pci-layerscape.c b/drivers/pci/host/pci-layerscape.c
-index 00feabf..3e2100d 100644
--- a/drivers/pci/host/pci-layerscape.c
+++ b/drivers/pci/host/pci-layerscape.c
-@@ -158,9 +158,14 @@ static void ls1021_pcie_host_init(struct pcie_port *pp)
+@@ -158,9 +158,14 @@ static void ls1021_pcie_host_init(struct
static int ls_pcie_link_up(struct pcie_port *pp)
{
struct ls_pcie *pcie = to_ls_pcie(pp);
- u32 state;
+ u32 state, offset;
-+
+
+- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
+ if (of_get_property(pp->dev->of_node, "fsl,lut_diff", NULL))
+ offset = 0x407fc;
+ else
+ offset = pcie->drvdata->lut_dbg;
-
-- state = (ioread32(pcie->lut + pcie->drvdata->lut_dbg) >>
++
+ state = (ioread32(pcie->lut + offset) >>
pcie->drvdata->ltssm_shift) &
LTSSM_STATE_MASK;
-@@ -261,7 +266,6 @@ static const struct of_device_id ls_pcie_of_match[] = {
+@@ -261,7 +266,6 @@ static const struct of_device_id ls_pcie
{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
{ .compatible = "fsl,ls1088a-pcie", .data = &ls1088_drvdata },
{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
@@ -88,7 +84,7 @@ index 00feabf..3e2100d 100644
{ },
};
MODULE_DEVICE_TABLE(of, ls_pcie_of_match);
-@@ -315,8 +319,7 @@ static int __init ls_pcie_probe(struct platform_device *pdev)
+@@ -315,8 +319,7 @@ static int __init ls_pcie_probe(struct p
if (!ls_pcie_is_bridge(pcie))
return -ENODEV;
@@ -98,6 +94,3 @@ index 00feabf..3e2100d 100644
of_device_is_compatible(pdev->dev.of_node, "fsl,ls1088a-pcie")) {
int len;
const u32 *prop;
---
-1.7.9.5
-