aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-04-10 10:47:05 +0800
committerPetr Štetiar <ynezz@true.cz>2020-05-07 12:53:06 +0200
commitcddd4591404fb4c53dc0b3c0b15b942cdbed4356 (patch)
tree392c1179de46b0f804e3789edca19069b64e6b44 /target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch
parentd1d2c0b5579ea4f69a42246c9318539d61ba1999 (diff)
downloadupstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.gz
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.bz2
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.zip
layerscape: add patches-5.4
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch80
1 files changed, 80 insertions, 0 deletions
diff --git a/target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch b/target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch
new file mode 100644
index 0000000000..04c14ca927
--- /dev/null
+++ b/target/linux/layerscape/patches-5.4/804-crypto-0034-LF-63-1-crypto-caam-fix-SM-test-init.patch
@@ -0,0 +1,80 @@
+From 79aa6ebf9d0b982c859a0c1bec1d879ff3d9ad29 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Horia=20Geant=C4=83?= <horia.geanta@nxp.com>
+Date: Wed, 27 Nov 2019 12:30:41 +0200
+Subject: [PATCH] LF-63-1 crypto: caam - fix SM test init
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit 77debf316c44 ("LFV-26 crypto: caam - fix Secure Memory driver init")
+addressed SM driver initialization and also update SM test.
+
+However, the fix for SM test is insufficient.
+There are cases when SM test runs before SM driver, causing a crash
+due to uninitialized "priv" pointer being dereferenced.
+
+The fix consists in the following:
+
+1. Since SM test is a "bare" device driver (doesn't sit on any bus),
+there is no deferred probing support.
+Thus we have no choice (*) but to abort SM tests with a notification.
+
+(*) We don't want to force SM driver running first by means of
+init levels etc. Just KISS.
+
+2. SM test driver forced to being built only as a module
+Since SM test driver's only goal is to run SM tests, it doesn't make
+any sense to be built-in.
+Building the driver as a module allows for running the tests
+several times if needed (multiple modprobe & rmmod cycles).
+
+Note: from the perspective of wanting to test repetitively, it would
+make sense to force module unloading by returning an error code
+in the module_init function.
+However, this might affect test scripts (due to error code and/or
+message output by unsuccessful module loading), so we postpone
+this change for now.
+
+Fixes: d02fe599d7d5 ("MLKU-25-3 crypto: caam - add Secure Memory support")
+Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
+Acked-by: Leonard Crestez <leonard.crestez@nxp.com>
+---
+ drivers/crypto/caam/Kconfig | 1 +
+ drivers/crypto/caam/Makefile | 2 +-
+ drivers/crypto/caam/sm_test.c | 4 ++++
+ 3 files changed, 6 insertions(+), 1 deletion(-)
+
+--- a/drivers/crypto/caam/Kconfig
++++ b/drivers/crypto/caam/Kconfig
+@@ -190,6 +190,7 @@ config CRYPTO_DEV_FSL_CAAM_SM_SLOTSIZE
+ config CRYPTO_DEV_FSL_CAAM_SM_TEST
+ tristate "CAAM Secure Memory - Keystore Test/Example (EXPERIMENTAL)"
+ depends on CRYPTO_DEV_FSL_CAAM_SM
++ depends on m
+ help
+ Example thread to exercise the Keystore API and to verify that
+ stored and recovered secrets can be used for general purpose
+--- a/drivers/crypto/caam/Makefile
++++ b/drivers/crypto/caam/Makefile
+@@ -24,7 +24,7 @@ caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_AHA
+ caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_RNG_API) += caamrng.o
+ caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_PKC_API) += caampkc.o pkc_desc.o
+ caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_SM) += sm_store.o
+-caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_SM_TEST) += sm_test.o
++obj-$(CONFIG_CRYPTO_DEV_FSL_CAAM_SM_TEST) += sm_test.o
+ caam_jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_SECVIO) += secvio.o
+ #caam-jr-$(CONFIG_CRYPTO_DEV_FSL_CAAM_TK_API) += tag_object.o
+
+--- a/drivers/crypto/caam/sm_test.c
++++ b/drivers/crypto/caam/sm_test.c
+@@ -552,6 +552,10 @@ static int __init caam_sm_test_init(void
+ of_node_put(dev_node);
+
+ priv = dev_get_drvdata(&pdev->dev);
++ if (!priv) {
++ dev_info(&pdev->dev, "SM driver not ready, aborting tests\n");
++ return -ENODEV;
++ }
+ if (!priv->sm_present) {
+ dev_info(&pdev->dev, "No SM support, skipping tests\n");
+ return -ENODEV;