aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-04-10 10:47:05 +0800
committerPetr Štetiar <ynezz@true.cz>2020-05-07 12:53:06 +0200
commitcddd4591404fb4c53dc0b3c0b15b942cdbed4356 (patch)
tree392c1179de46b0f804e3789edca19069b64e6b44 /target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch
parentd1d2c0b5579ea4f69a42246c9318539d61ba1999 (diff)
downloadupstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.gz
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.tar.bz2
upstream-cddd4591404fb4c53dc0b3c0b15b942cdbed4356.zip
layerscape: add patches-5.4
Add patches for linux-5.4. The patches are from NXP LSDK-20.04 release which was tagged LSDK-20.04-V5.4. https://source.codeaurora.org/external/qoriq/qoriq-components/linux/ For boards LS1021A-IOT, and Traverse-LS1043 which are not involved in LSDK, port the dts patches from 4.14. The patches are sorted into the following categories: 301-arch-xxxx 302-dts-xxxx 303-core-xxxx 701-net-xxxx 801-audio-xxxx 802-can-xxxx 803-clock-xxxx 804-crypto-xxxx 805-display-xxxx 806-dma-xxxx 807-gpio-xxxx 808-i2c-xxxx 809-jailhouse-xxxx 810-keys-xxxx 811-kvm-xxxx 812-pcie-xxxx 813-pm-xxxx 814-qe-xxxx 815-sata-xxxx 816-sdhc-xxxx 817-spi-xxxx 818-thermal-xxxx 819-uart-xxxx 820-usb-xxxx 821-vfio-xxxx Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch')
-rw-r--r--target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch b/target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch
new file mode 100644
index 0000000000..6819b0ec9f
--- /dev/null
+++ b/target/linux/layerscape/patches-5.4/701-net-0323-staging-fsl_ppfe-eth-add-pfe-support-to-Kconfig-and-.patch
@@ -0,0 +1,48 @@
+From 022999fe6c4008d1ca6ec0f33d7f7c88db97f3fa Mon Sep 17 00:00:00 2001
+From: Calvin Johnson <calvin.johnson@nxp.com>
+Date: Wed, 1 Nov 2017 11:11:30 +0530
+Subject: [PATCH] staging: fsl_ppfe/eth: add pfe support to Kconfig and
+ Makefile
+
+Signed-off-by: Calvin Johnson <calvin.johnson@nxp.com>
+[ Aisheng: fix minor conflict due to removed VBOXSF_FS ]
+Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
+---
+ MAINTAINERS | 8 ++++++++
+ drivers/staging/Kconfig | 1 +
+ drivers/staging/Makefile | 1 +
+ 3 files changed, 10 insertions(+)
+
+--- a/MAINTAINERS
++++ b/MAINTAINERS
+@@ -6574,6 +6574,14 @@ F: drivers/ptp/ptp_qoriq_debugfs.c
+ F: include/linux/fsl/ptp_qoriq.h
+ F: Documentation/devicetree/bindings/ptp/ptp-qoriq.txt
+
++FREESCALE QORIQ PPFE ETHERNET DRIVER
++M: Anji Jagarlmudi <anji.jagarlmudi@nxp.com>
++M: Calvin Johnson <calvin.johnson@nxp.com>
++L: netdev@vger.kernel.org
++S: Maintained
++F: drivers/staging/fsl_ppfe
++F: Documentation/devicetree/bindings/net/fsl_ppfe/pfe.txt
++
+ FREESCALE QUAD SPI DRIVER
+ M: Han Xu <han.xu@nxp.com>
+ L: linux-spi@vger.kernel.org
+--- a/drivers/staging/Kconfig
++++ b/drivers/staging/Kconfig
+@@ -126,5 +126,6 @@ source "drivers/staging/exfat/Kconfig"
+ source "drivers/staging/qlge/Kconfig"
+
+ source "drivers/staging/fsl_qbman/Kconfig"
++source "drivers/staging/fsl_ppfe/Kconfig"
+
+ endif # STAGING
+--- a/drivers/staging/Makefile
++++ b/drivers/staging/Makefile
+@@ -54,3 +54,4 @@ obj-$(CONFIG_USB_WUSB) += wusbcore/
+ obj-$(CONFIG_EXFAT_FS) += exfat/
+ obj-$(CONFIG_QLGE) += qlge/
+ obj-$(CONFIG_FSL_SDK_DPA) += fsl_qbman/
++obj-$(CONFIG_FSL_PPFE) += fsl_ppfe/