aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-07-04 17:46:52 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commita5ad3a2c808afb26db6dd54b0f974c9c902f0521 (patch)
treee02a2217006da9a0d8a4e654045af223513de956 /target/linux/layerscape/image
parent2e2203ff72fd1556bab2c32e808ce7bb79a9858c (diff)
downloadupstream-a5ad3a2c808afb26db6dd54b0f974c9c902f0521.tar.gz
upstream-a5ad3a2c808afb26db6dd54b0f974c9c902f0521.tar.bz2
upstream-a5ad3a2c808afb26db6dd54b0f974c9c902f0521.zip
layerscape: update memory layout according to LSDK
The uniform memory layout of NOR/QSPI/NAND/SD media on all Layerscape platforms: +-----------------------------+---------|--------------|-----------------+ |Firmwre Definition | MaxSize | Flash Offset | SD Start Block #| |-----------------------------|---------|--------------|-----------------| |RCW+PBI | 1MB | 0x00000000 | 0x00008 | |-----------------------------|---------|--------------|-----------------| |Boot firmware(U-Boot,UEFI) | 2MB | 0x00100000 | 0x00800 | |-----------------------------|---------|--------------|-----------------| |Boot firmware Environment | 1MB | 0x00300000 | 0x01800 | |-----------------------------|---------|--------------|-----------------| |PPA firmware | 2MB | 0x00400000 | 0x02000 | |-----------------------------|---------|--------------|-----------------| |Secure boot headers | 3MB | 0x00600000 | 0x03000 | |-----------------------------|---------|--------------|-----------------| |DPAA1 FMAN ucode | 256KB | 0x00900000 | 0x04800 | |-----------------------------|---------|--------------|-----------------| |QE/uQE firmware | 256KB | 0x00940000 | 0x04A00 | |-----------------------------|---------|--------------|-----------------| |Ethernet PHY firmware | 256KB | 0x00980000 | 0x04C00 | |-----------------------------|---------|--------------|-----------------| |Scripts | 256KB | 0x009C0000 | 0x04E00 | |-----------------------------|---------|--------------|-----------------| |DPAA2 MC firmware | 3MB | 0x00A00000 | 0x05000 | |-----------------------------|---------|--------------|-----------------| |DPAA2 DPL | 1MB | 0x00D00000 | 0x06800 | |-----------------------------|---------|--------------|-----------------| |DPAA2 DPC | 1MB | 0x00E00000 | 0x07000 | |-----------------------------|---------|--------------|-----------------| |Device tree(needed by uefi) | 1MB | 0x00F00000 | 0x07800 | |-------------+---------------|---------|--------------|-----------------| |Kernel | | 16MB | 0x01000000 | 0x08000 | |-------------| kernel.itb |---------|--------------|-----------------| |Ramdisk rfs | |32MB | 0x01100000 | 0x08800 | +-------------+---------------+---------|--------------|-----------------+ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile36
1 files changed, 23 insertions, 13 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 9d5b6e4543..7f672d7db5 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -51,9 +51,12 @@ define Device/ls1043ardb
DEVICE_TITLE := ls1043ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1043ardb uboot-layerscape-$(SUBTARGET)-ls1043ardb fman-layerscape-ls1043ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1043a-rdb
- IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
- append-ls-fman $(1) | pad-to 4M | append-ls-dtb $$(DEVICE_DTS) | pad-to 5M | \
- append-kernel | pad-to 10M | append-rootfs | pad-rootfs | check-size 67108865
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 9M | \
+ append-ls-fman $(1) | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls1043ardb
@@ -61,9 +64,12 @@ define Device/ls1046ardb
DEVICE_TITLE := ls1046ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1046ardb uboot-layerscape-$(SUBTARGET)-ls1046ardb fman-layerscape-ls1046ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1046a-rdb
- IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
- append-ls-fman $(1) | pad-to 4M | append-ls-dtb $$(DEVICE_DTS) | pad-to 5M | \
- append-kernel | pad-to 10M | append-ls-rootfs-ext4 $(1) 22M | check-size 33554433
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 9M | \
+ append-ls-fman $(1) | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-ls-rootfs-ext4 $(1) 22M | check-size 67108865
endef
TARGET_DEVICES += ls1046ardb
@@ -71,9 +77,11 @@ define Device/ls1012ardb
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb kmod-ppfe ppfe-ls1012ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
- IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | append-ls-uboot $(1) | pad-to 3M | \
- append-ls-dtb $$(DEVICE_DTS) | pad-to 4M | append-kernel | pad-to 9M | \
- append-ls-rootfs-ext4 $(1) 23M | check-size 33554433
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-ls-rootfs-ext4 $(1) 23M | check-size 67108865
endef
TARGET_DEVICES += ls1012ardb
@@ -81,8 +89,9 @@ define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb mc-binary-ls1088ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
- IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | append-kernel | pad-to 6M | \
- append-ls-rootfs-ext4 $(1) 17M | check-size 24117249
+ IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | \
+ append-kernel | pad-to 17M | \
+ append-ls-rootfs-ext4 $(1) 17M | check-size 51380225
endef
TARGET_DEVICES += ls1088ardb
@@ -90,8 +99,9 @@ define Device/ls2088ardb
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb mc-binary-ls2088ardb
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
- IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | append-kernel | pad-to 6M | \
- append-rootfs | pad-rootfs | check-size 24117249
+ IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | \
+ append-kernel | pad-to 17M | \
+ append-rootfs | pad-rootfs | check-size 51380225
endef
TARGET_DEVICES += ls2088ardb