aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-26 15:33:00 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:49 +0100
commit82fbca8aaa6b35d96e555bc6c2edbda1fde21b11 (patch)
treedf275d34a1cce5cef7a72f5d30a60a5277a47ea3 /target/linux/layerscape/image
parent669c02d46d765c16104135859f2edb21fbafb605 (diff)
downloadupstream-82fbca8aaa6b35d96e555bc6c2edbda1fde21b11.tar.gz
upstream-82fbca8aaa6b35d96e555bc6c2edbda1fde21b11.tar.bz2
upstream-82fbca8aaa6b35d96e555bc6c2edbda1fde21b11.zip
layerscape: support LSDK ppfe
This patch is to use ppfe git tree on LSDK github instead of private git tree, and support the latest ppfe on ls1012ardb. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 165ed0e98f..85a6b822eb 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -24,6 +24,10 @@ define Build/append-ls-mc
dd if=$(STAGING_DIR_IMAGE)/$(1)-mc.itb >> $@
endef
+define Build/append-ls-ppfe
+ dd if=$(STAGING_DIR_IMAGE)/pfe.itb >> $@
+endef
+
define Build/append-ls-dpl
dd if=$(STAGING_DIR_IMAGE)/$(1)-dpl.dtb >> $@
endef
@@ -89,10 +93,12 @@ TARGET_DEVICES += ls1046ardb
define Device/ls1012ardb
DEVICE_TITLE := ls1012ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb kmod-ppfe ppfe-ls1012ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls1012ardb uboot-layerscape-$(SUBTARGET)-ls1012ardb \
+ kmod-ppfe layerscape-ppfe
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-rdb
IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
- append-ls-uboot $(1) | pad-to 15M | \
+ append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-ppfe | pad-to 15M | \
append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
append-kernel | pad-to 32M | \
append-ls-rootfs-ext4 $(1) 23M | check-size 67108865