aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYutang Jiang <yutang.jiang@nxp.com>2016-12-28 01:28:02 +0800
committerJo-Philipp Wich <jo@mein.io>2017-01-03 15:19:15 +0100
commit799d0dddf608ff012b49282d5832ddd2ef1b916e (patch)
tree9ecd5688dbc1283091090d99165f31ad9ecef11d /target/linux/layerscape/image
parent1866368a8ab8cacf73aa47f67138040d5620439d (diff)
downloadupstream-799d0dddf608ff012b49282d5832ddd2ef1b916e.tar.gz
upstream-799d0dddf608ff012b49282d5832ddd2ef1b916e.tar.bz2
upstream-799d0dddf608ff012b49282d5832ddd2ef1b916e.zip
layerscape: add ls2088ardb device support
The QorIQ LS2088A processor is built on the Layerscape architecture combining eight ARM A72 processor cores with advanced, high-performance datapath acceleration and network, peripheral interfaces required for networking, telecom, wireless infrastructure, aerospace applications and general-purpose embedded applications. Features summary: - Eight 64-bit ARM v8 Cortex-A72 CPUs - Two 64-bit DDR4 SDRAM memory controller with ECC - One 32-bit DDR3 SDRAM memory controller with ECC - Data path acceleration architecture 2.0 (DPAA2) - Ethernet interfaces - IFC, 4 PCIe, 2 SATA, 2 USB, 1 SDXC, 2 DUARTs etc Signed-off-by: Yutang Jiang <yutang.jiang@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index c70955785b..341d5fbda0 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -106,4 +106,18 @@ endif
endef
TARGET_DEVICES += ls1088ardb
+define Device/ls2088ardb
+ DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
+ DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb mc-binary-ls2088ardb
+ifeq ($(SUBTARGET),64b)
+ DEVICE_DTS = freescale/fsl-ls2088a-rdb
+endif
+ifeq ($(SUBTARGET),32b)
+ DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
+endif
+ IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | append-kernel | pad-to 6M | \
+ append-rootfs | pad-rootfs | check-size 24117249
+endef
+TARGET_DEVICES += ls2088ardb
+
$(eval $(call BuildImage))