aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/image
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-24 18:07:38 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:49 +0100
commit2b1ec44dbd3cd3419231bb88bf9881333ae445c5 (patch)
treef156c44c0374d34d6778448416abe13799b75f27 /target/linux/layerscape/image
parent9e7b1667046201b2d52108d6c8769bebd4f6736c (diff)
downloadupstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.tar.gz
upstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.tar.bz2
upstream-2b1ec44dbd3cd3419231bb88bf9881333ae445c5.zip
layerscape: add ls1012afrdm device support
The QorIQ FRDM-LS1012A Board is an ultra-low-cost development platform for QorIQ LS1012A Series Network Processors built on ARM Cortex-A53 processor. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/image')
-rw-r--r--target/linux/layerscape/image/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 26c57678f1..88bf8d7b40 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -114,6 +114,21 @@ define Device/ls1012ardb
endef
TARGET_DEVICES += ls1012ardb
+define Device/ls1012afrdm
+ DEVICE_TITLE := ls1012afrdm-$(SUBTARGET)
+ DEVICE_PACKAGES += rcw-layerscape-ls1012afrdm uboot-layerscape-$(SUBTARGET)-ls1012afrdm \
+ kmod-ppfe layerscape-ppfe layerscape-ppa-ls1012afrdm
+ DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1012a-frdm
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 4M | \
+ append-ls-ppa $(1) | pad-to 10M | \
+ append-ls-ppfe | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-ls-rootfs-ext4 $(1) 30M | check-size 67108865
+endef
+TARGET_DEVICES += ls1012afrdm
+
ifeq ($(SUBTARGET),armv8_64b)
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)