aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/armv7/target.mk
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2018-07-10 11:58:59 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2018-09-22 21:20:57 +0200
commitf0ec7bd27d206ea0eb9587e178ce0d7ddc006bce (patch)
treee5a732d69a332010950f3f800838c8a14390a60c /target/linux/layerscape/armv7/target.mk
parent0d95eb2cce62102a849e8c9552c30dfee3fe6189 (diff)
downloadupstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.gz
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.tar.bz2
upstream-f0ec7bd27d206ea0eb9587e178ce0d7ddc006bce.zip
layerscape: add armv7 subtarget and ls1021atwr board support
The NXP TWR-LS1021A module is a development system based on the QorIQ LS1021A processor. - This feature-rich, high-performance processor module can be used standalone or as part of an assembled Tower System development platform. - Incorporating dual Arm Cortex-A7 cores running up to 1 GHz, the TWR-LS1021A delivers an outstanding level of performance. - The TWR-LS1021A offers HDMI, SATA3 and USB3 connectors as well as a complete Linux software developer's package. - The module provides a comprehensive level of security that includes support for secure boot, Trust Architecture and tamper detection in both standby and active power modes, safeguarding the device from manufacture to deployment. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/armv7/target.mk')
-rw-r--r--target/linux/layerscape/armv7/target.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/layerscape/armv7/target.mk b/target/linux/layerscape/armv7/target.mk
new file mode 100644
index 0000000000..bfc6c09d42
--- /dev/null
+++ b/target/linux/layerscape/armv7/target.mk
@@ -0,0 +1,16 @@
+#
+# Copyright 2018 NXP
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+ARCH:=arm
+BOARDNAME:=ARMv7 based boards
+CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=neon-vfpv4
+KERNELNAME:=zImage dtbs
+
+define Target/Description
+ Build firmware images for NXP Layerscape ARMv7 based boards.
+endef