aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-06-29 11:19:07 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit806624add541bd828516a58aab20ae19ae9e431f (patch)
treee5bb450e4b18defde11492f2a3578f1ad04e8163 /target/linux/layerscape/Makefile
parent4c89f2fcf8f6579257342cfca47293c0ac16fe86 (diff)
downloadupstream-806624add541bd828516a58aab20ae19ae9e431f.tar.gz
upstream-806624add541bd828516a58aab20ae19ae9e431f.tar.bz2
upstream-806624add541bd828516a58aab20ae19ae9e431f.zip
layerscape: rename subtargets and update makefile files
Rename subtargets 32b/64b with armv8_32b/armv8_64b which are more proper, and update makefile files. There also will be other subtargets added in the future, like armv7. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'target/linux/layerscape/Makefile')
-rw-r--r--target/linux/layerscape/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/layerscape/Makefile b/target/linux/layerscape/Makefile
index 3def184b94..c2d3cc07af 100644
--- a/target/linux/layerscape/Makefile
+++ b/target/linux/layerscape/Makefile
@@ -12,15 +12,15 @@ DEVICE_TYPE:=developerboard
KERNEL_PATCHVER:=4.4
KERNELNAME:=Image dtbs
FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
+SUBTARGETS:=armv8_64b armv8_32b
MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
-include $(INCLUDE_DIR)/target.mk
-
define Target/Description
- Build firmware images for $(BOARDNAME) SoC devices.
+ Build firmware images for NXP Layerscape based boards.
endef
+include $(INCLUDE_DIR)/target.mk
+
DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
$(eval $(call BuildTarget))