aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-05-20 08:37:45 +0200
committerFelix Baumann <felix.bau@gmx.de>2023-05-21 01:08:22 +0200
commitf5cb556d4f70e7aac428857fe782b58ece0cf188 (patch)
tree5cb0a1675cfec759d97837e3e9fdad955879f21c /target/linux/lantiq
parent3f297be1ed49351282f26462a7aa6e03036a1ffc (diff)
downloadupstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.gz
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.bz2
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.zip
treewide: Disable building 32M RAM devices
Following deprecation notice[1] in 21.02, disable targets with 32M of RAM [1] https://openwrt.org/supported_devices/864_warning Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/ar9.mk1
-rw-r--r--target/linux/lantiq/image/danube.mk2
-rw-r--r--target/linux/lantiq/image/vr9.mk2
3 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/ar9.mk b/target/linux/lantiq/image/ar9.mk
index 9a0d68433c..3a301f3655 100644
--- a/target/linux/lantiq/image/ar9.mk
+++ b/target/linux/lantiq/image/ar9.mk
@@ -154,6 +154,7 @@ define Device/zte_h201l
kmod-usb-dwc2 kmod-usb-ledtrig-usbport \
kmod-ltq-tapi kmod-ltq-vmmc
SUPPORTED_DEVICES += H201L
+ DEFAULT := n
endef
TARGET_DEVICES += zte_h201l
diff --git a/target/linux/lantiq/image/danube.mk b/target/linux/lantiq/image/danube.mk
index a54cb3117d..c2bf7e798b 100644
--- a/target/linux/lantiq/image/danube.mk
+++ b/target/linux/lantiq/image/danube.mk
@@ -12,6 +12,7 @@ define Device/arcadyan_arv4510pw
kmod-ltq-tapi kmod-ltq-vmmc \
kmod-rt2800-pci kmod-ath5k wpad-basic-mbedtls
SUPPORTED_DEVICES += ARV4510PW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4510pw
@@ -219,5 +220,6 @@ define Device/siemens_gigaset-sx76x
ltq-adsl-app ppp-mod-pppoe \
kmod-ath5k wpad-basic-mbedtls
SUPPORTED_DEVICES += GIGASX76X
+ DEFAULT := n
endef
TARGET_DEVICES += siemens_gigaset-sx76x
diff --git a/target/linux/lantiq/image/vr9.mk b/target/linux/lantiq/image/vr9.mk
index f3149bf2c0..3c05636f56 100644
--- a/target/linux/lantiq/image/vr9.mk
+++ b/target/linux/lantiq/image/vr9.mk
@@ -12,6 +12,7 @@ define Device/alphanetworks_asl56026
DEVICE_ALT0_VENDOR := BT Openreach
DEVICE_ALT0_MODEL := ECI VDSL Modem V-2FUb/I
IMAGE_SIZE := 7488k
+ DEFAULT := n
endef
TARGET_DEVICES += alphanetworks_asl56026
@@ -38,6 +39,7 @@ define Device/arcadyan_vg3503j
DEVICE_MODEL := ECI VDSL Modem V-2FUb/R
IMAGE_SIZE := 8000k
SUPPORTED_DEVICES += VG3503J
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_vg3503j