aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-25 20:29:15 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-29 12:08:16 +0200
commit6da53561950034da93d79db787e64fb5829c1ffe (patch)
treeb99b8e1ce849f56c5867ff073169ae96ddd5dc79 /target/linux/lantiq
parent55e2d5eb3b44e5a2c7e1b0bae4fcd738e45bfac9 (diff)
downloadupstream-6da53561950034da93d79db787e64fb5829c1ffe.tar.gz
upstream-6da53561950034da93d79db787e64fb5829c1ffe.tar.bz2
upstream-6da53561950034da93d79db787e64fb5829c1ffe.zip
lantiq: disable default build for devices with 4M flash
It has been decided that the 19.07 release will be last one to include 4/32 devices. This disables default build for all devices with 4M flash on lantiq. Note that this will affect _all_ devices for amazonse ("ase") and xway_legacy subtarget. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/amazonse.mk4
-rw-r--r--target/linux/lantiq/image/danube.mk3
-rw-r--r--target/linux/lantiq/image/falcon.mk2
-rw-r--r--target/linux/lantiq/image/xway_legacy.mk5
4 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/amazonse.mk b/target/linux/lantiq/image/amazonse.mk
index 4a23a68e40..1fd714dee4 100644
--- a/target/linux/lantiq/image/amazonse.mk
+++ b/target/linux/lantiq/image/amazonse.mk
@@ -5,16 +5,18 @@ define Device/allnet_all0333cj
DEVICE_PACKAGES := kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
ltq-adsl-app ppp-mod-pppoe
+ DEFAULT := n
endef
TARGET_DEVICES += allnet_all0333cj
define Device/netgear_dgn1000b
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := DGN1000B
- IMAGE_SIZE := 6000k
+ IMAGE_SIZE := 3712k
DEVICE_PACKAGES := kmod-ltq-adsl-ase kmod-ltq-adsl-ase-mei \
kmod-ltq-adsl-ase-fw-b kmod-ltq-atm-ase \
ltq-adsl-app ppp-mod-pppoe
SUPPORTED_DEVICES += DGN1000B
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_dgn1000b
diff --git a/target/linux/lantiq/image/danube.mk b/target/linux/lantiq/image/danube.mk
index 2fb5ea061f..6ba9a91fb2 100644
--- a/target/linux/lantiq/image/danube.mk
+++ b/target/linux/lantiq/image/danube.mk
@@ -29,6 +29,7 @@ define Device/arcadyan_arv4519pw
kmod-ltq-adsl-danube-fw-a kmod-ltq-atm-danube \
ltq-adsl-app ppp-mod-pppoa
SUPPORTED_DEVICES += ARV4519PW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4519pw
@@ -110,6 +111,7 @@ define Device/arcadyan_arv7525pw
kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
ltq-adsl-app ppp-mod-pppoa -swconfig
SUPPORTED_DEVICES += ARV4510PW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv7525pw
@@ -201,6 +203,7 @@ define Device/lantiq_easy50712
DEVICE_MODEL := Danube (EASY50712)
SOC := danube
IMAGE_SIZE := 3776k
+ DEFAULT := n
endef
TARGET_DEVICES += lantiq_easy50712
diff --git a/target/linux/lantiq/image/falcon.mk b/target/linux/lantiq/image/falcon.mk
index a5490f6e68..6269cf6858 100644
--- a/target/linux/lantiq/image/falcon.mk
+++ b/target/linux/lantiq/image/falcon.mk
@@ -57,6 +57,7 @@ define Device/lantiq_easy98000-nand
DEVICE_VARIANT := NAND
IMAGE_SIZE := 3904k
DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+ DEFAULT := n
endef
TARGET_DEVICES += lantiq_easy98000-nand
@@ -66,6 +67,7 @@ define Device/lantiq_easy98000-nor
DEVICE_VARIANT := NOR
IMAGE_SIZE := 3904k
DEVICE_PACKAGES := kmod-dm9000 kmod-i2c-lantiq kmod-eeprom-at24
+ DEFAULT := n
endef
TARGET_DEVICES += lantiq_easy98000-nor
diff --git a/target/linux/lantiq/image/xway_legacy.mk b/target/linux/lantiq/image/xway_legacy.mk
index 52a29ab2f0..2eaefd2cdd 100644
--- a/target/linux/lantiq/image/xway_legacy.mk
+++ b/target/linux/lantiq/image/xway_legacy.mk
@@ -8,6 +8,7 @@ define Device/arcadyan_arv4518pwr01
ltq-adsl-app ppp-mod-pppoa \
kmod-ath5k wpad-mini
SUPPORTED_DEVICES += ARV4518PWR01
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4518pwr01
@@ -21,6 +22,7 @@ define Device/arcadyan_arv4518pwr01a
ltq-adsl-app ppp-mod-pppoa \
kmod-ath5k wpad-basic
SUPPORTED_DEVICES += ARV4518PWR01A
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4518pwr01a
@@ -38,6 +40,7 @@ define Device/arcadyan_arv4520pw
ltq-adsl-app ppp-mod-pppoa \
kmod-rt61-pci wpad-mini
SUPPORTED_DEVICES += ARV4520PW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4520pw
@@ -53,6 +56,7 @@ define Device/arcadyan_arv4525pw
kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
ltq-adsl-app ppp-mod-pppoa -swconfig
SUPPORTED_DEVICES += ARV4525PW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv4525pw
@@ -68,5 +72,6 @@ define Device/arcadyan_arv452cqw
kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
ltq-adsl-app ppp-mod-pppoa
SUPPORTED_DEVICES += ARV452CQW
+ DEFAULT := n
endef
TARGET_DEVICES += arcadyan_arv452cqw