aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-08-09 23:45:56 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-11 12:54:57 +0200
commitb72fa3e4a8357d46eed35dfcae436e053a4b06c7 (patch)
treedfd833601827c6894290edc9cbaaa86293f8cb3f /target/linux/lantiq
parent5355665cc8dff19510aa129723e5e935f16b03ad (diff)
downloadupstream-b72fa3e4a8357d46eed35dfcae436e053a4b06c7.tar.gz
upstream-b72fa3e4a8357d46eed35dfcae436e053a4b06c7.tar.bz2
upstream-b72fa3e4a8357d46eed35dfcae436e053a4b06c7.zip
lantiq: enable second VPE on Fritz!Box 7412
The AVM Fritz!Box 7412 does not use the VMMC part of the Lantiq chip but rather a proprietary solution based on the DECT chip for the FXS ports. Therefore, the second VPE can be enabled for use with OpenWrt. Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 891a7007598d5d396bf621fcc6ab0cc083b192b6)
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7412.dts2
-rw-r--r--target/linux/lantiq/image/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7412.dts b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7412.dts
index 14a4bf77b9..143ec061bb 100644
--- a/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7412.dts
+++ b/target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7412.dts
@@ -11,7 +11,7 @@
model = "AVM FRITZ!Box 7412";
chosen {
- bootargs = "console=ttyLTQ0,115200 mem=126M vpe1_load_addr=0x87e00000 vpe1_mem=2M maxvpes=1 maxtcs=1 nosmp";
+ bootargs = "console=ttyLTQ0,115200";
};
aliases {
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2352cb6b5e..f71a262c82 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -673,7 +673,7 @@ define Device/avm_fritz7412
KERNEL_SIZE := 4096k
IMAGE_SIZE := 49152k
DEVICE_TITLE := AVM FRITZ!Box 7412
- DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-ltq-tapi kmod-ltq-vmmc fritz-tffs-nand fritz-caldata
+ DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic fritz-tffs-nand fritz-caldata
endef
TARGET_DEVICES += avm_fritz7412