aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-07 18:20:31 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-07 18:20:31 +0000
commit93a8f2cb576b8b8ce0817e22d10ab5628a5c9f8d (patch)
tree7c216f2afdd06cea2a7736fc9a616b79e7a192ff /target/linux/lantiq
parente5333d905943082b975fbe644a7d68869c8785b1 (diff)
downloadupstream-93a8f2cb576b8b8ce0817e22d10ab5628a5c9f8d.tar.gz
upstream-93a8f2cb576b8b8ce0817e22d10ab5628a5c9f8d.tar.bz2
upstream-93a8f2cb576b8b8ce0817e22d10ab5628a5c9f8d.zip
fix lantiq image makefile to represent new split between ar9 and danube
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27537 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile29
1 files changed, 20 insertions, 9 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index b1ef0a5cde..43ad0e88f3 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -136,14 +136,6 @@ define Image/Build/Profile/ARV752DPW22
$(call Image/Build/$(1),$(1),ARV752DPW22)
endef
-define Image/BuildKernel/Profile/DGN3500B
- $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
-endef
-
-define Image/Build/Profile/DGN3500B
- $(call Image/Build/$(1),$(1),DGN3500B)
-endef
-
define Image/BuildKernel/Profile/GIGASX76X
$(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
endef
@@ -166,7 +158,6 @@ define Image/BuildKernel/Profile/Generic
$(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
$(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
$(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
- $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
@@ -184,6 +175,26 @@ define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),ARV752DPW)
$(call Image/Build/$(1),$(1),ARV752DPW22)
$(call Image/Build/$(1),$(1),GIGASX76X)
+ $(call Image/Build/$(1),$(1),NONE)
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+endef
+endif
+
+ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/DGN3500B
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+ $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
+define Image/BuildKernel/Profile/Generic
+ $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+ $(call Image/BuildKernel/Template,NONE)
+endef
+
+define Image/Build/Profile/Generic
$(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs