aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2010-12-12 22:57:16 +0000
committerJohn Crispin <john@openwrt.org>2010-12-12 22:57:16 +0000
commit9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55 (patch)
tree3d80c2524b0e73b5f7c9982eca4fe9301efdf75a /target/linux/lantiq/xway
parentf590b304ef7d22242e08c86866cbb37927f0a404 (diff)
downloadupstream-9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55.tar.gz
upstream-9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55.tar.bz2
upstream-9f47e80bb30bed05ebcdfe671d4f2a9e9c7bfe55.zip
adds new lantiq kernel. once the codebase is fully tested and know to be working on all the devices previously supported by ifxmips, we will drop ifxmips support.
SVN-Revision: 24526
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/config-default21
-rw-r--r--target/linux/lantiq/xway/target.mk11
2 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
new file mode 100644
index 0000000000..46cd6e778b
--- /dev/null
+++ b/target/linux/lantiq/xway/config-default
@@ -0,0 +1,21 @@
+# CONFIG_ARCH_PHYS_ADDR_T_64BIT is not set
+# CONFIG_CRYPTO_HW is not set
+CONFIG_HAVE_IDE=y
+CONFIG_HW_HAS_PCI=y
+CONFIG_IMAGE_CMDLINE_HACK=y
+CONFIG_LANTIQ_ETOP=y
+CONFIG_LANTIQ_MACH_ARV45XX=y
+CONFIG_LANTIQ_MACH_EASY4010=y
+CONFIG_LANTIQ_MACH_EASY50712=y
+CONFIG_LANTIQ_MACH_EASY50812=y
+# CONFIG_LANTIQ_PROM_ASC0 is not set
+CONFIG_LANTIQ_PROM_ASC1=y
+CONFIG_LANTIQ_WDT=y
+CONFIG_LEDS_GPIO=y
+# CONFIG_LOONGSON_MC146818 is not set
+CONFIG_LOONGSON_UART_BASE=y
+CONFIG_NEED_DMA_MAP_STATE=y
+CONFIG_SCSI_MOD=y
+CONFIG_SOC_LANTIQ=y
+CONFIG_SOC_LANTIQ_XWAY=y
+CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
new file mode 100644
index 0000000000..e2e2a6f12b
--- /dev/null
+++ b/target/linux/lantiq/xway/target.mk
@@ -0,0 +1,11 @@
+ARCH:=mips
+SUBTARGET:=xway
+BOARDNAME:=Xway
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=uboot-lantiq-easy50712 kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control ifx-tapidemo
+
+define Target/Description
+ Lantiq XWAY (danube/twinpass/ar9)
+endef
+