aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-11-02 20:07:36 +0000
committerJohn Crispin <john@openwrt.org>2012-11-02 20:07:36 +0000
commitdc8641f7fa670ede9f6c464bd7c6d1b2f94dee46 (patch)
tree83e923b4c4f3670811e33e059973e1e65e747c34 /target/linux/lantiq/xway
parentdd619da4fc9cd33553ce2deb145ec6321e4c43e2 (diff)
downloadupstream-dc8641f7fa670ede9f6c464bd7c6d1b2f94dee46.tar.gz
upstream-dc8641f7fa670ede9f6c464bd7c6d1b2f94dee46.tar.bz2
upstream-dc8641f7fa670ede9f6c464bd7c6d1b2f94dee46.zip
add subtarget, as of 3.6 we dont seperate xway SoC
SVN-Revision: 34062
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/config-default18
-rw-r--r--target/linux/lantiq/xway/profiles/001-lantiq.mk19
-rw-r--r--target/linux/lantiq/xway/target.mk10
3 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
new file mode 100644
index 0000000000..655784a9b6
--- /dev/null
+++ b/target/linux/lantiq/xway/config-default
@@ -0,0 +1,18 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_FIRMWARE_IN_KERNEL=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+# CONFIG_ISDN is not set
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+CONFIG_MTD_NAND_XWAY=y
+# CONFIG_MTD_PHYSMAP_OF is not set
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_PROC_DEVICETREE is not set
+CONFIG_RTL8306_PHY=y
+CONFIG_SPI=y
+CONFIG_SPI_MASTER=y
+CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/xway/profiles/001-lantiq.mk b/target/linux/lantiq/xway/profiles/001-lantiq.mk
new file mode 100644
index 0000000000..2c24d3c95e
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/001-lantiq.mk
@@ -0,0 +1,19 @@
+define Profile/EASY80920-NOR
+ NAME:=EASY80920-NOR
+endef
+
+define Profile/EASY80920-NOR/Description
+ Lantiq EASY80920 evalkit (NOR)
+endef
+
+$(eval $(call Profile,EASY80920-NOR))
+
+define Profile/EASY80920-NAND
+ NAME:=EASY80920-NAND
+endef
+
+define Profile/EASY80920-NAND/Description
+ Lantiq EASY80920 evalkit (NAND)
+endef
+
+$(eval $(call Profile,EASY80920-NAND))
diff --git a/target/linux/lantiq/xway/target.mk b/target/linux/lantiq/xway/target.mk
new file mode 100644
index 0000000000..6674665ccb
--- /dev/null
+++ b/target/linux/lantiq/xway/target.mk
@@ -0,0 +1,10 @@
+ARCH:=mips
+SUBTARGET:=xway
+BOARDNAME:=XWAY
+FEATURES:=squashfs jffs2 atm
+
+DEFAULT_PACKAGES+=swconfig kmod-leds-gpio kmod-button-hotplug
+
+define Target/Description
+ Lantiq XWAY
+endef