aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-06-08 17:57:55 +0000
committerJohn Crispin <blogic@openwrt.org>2011-06-08 17:57:55 +0000
commite558a1dec9373aca5c3cc204174cb365c84f2af2 (patch)
treeffd7da1e43d27e2a2244b1a7c54a3dd1307e6057 /target/linux/lantiq/xway
parent3c9611d54fec763c83f060574b31e417b1f0e66b (diff)
downloadupstream-e558a1dec9373aca5c3cc204174cb365c84f2af2.tar.gz
upstream-e558a1dec9373aca5c3cc204174cb365c84f2af2.tar.bz2
upstream-e558a1dec9373aca5c3cc204174cb365c84f2af2.zip
[lantiq]
* fixes spi flash for ar9 * adds limited support for netgear dgn3500 (enough for others to start working with) git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27137 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/xway')
-rw-r--r--target/linux/lantiq/xway/config-default3
-rw-r--r--target/linux/lantiq/xway/profiles/003-netgear.mk11
2 files changed, 13 insertions, 1 deletions
diff --git a/target/linux/lantiq/xway/config-default b/target/linux/lantiq/xway/config-default
index dd59fa68d2..5ef2fb3463 100644
--- a/target/linux/lantiq/xway/config-default
+++ b/target/linux/lantiq/xway/config-default
@@ -26,9 +26,9 @@ CONFIG_INPUT_POLLDEV=y
CONFIG_LANTIQ_ETOP=y
CONFIG_LANTIQ_MACH_ARV45XX=y
CONFIG_LANTIQ_MACH_EASY50712=y
+CONFIG_LANTIQ_MACH_NETGEAR=y
CONFIG_MACH_NO_WESTBRIDGE=y
# CONFIG_MINIX_FS_NATIVE_ENDIAN is not set
-# CONFIG_MTD_LATCH_ADDR is not set
CONFIG_NEED_DMA_MAP_STATE=y
CONFIG_NEED_PER_CPU_KM=y
CONFIG_PCI=y
@@ -44,6 +44,7 @@ CONFIG_SOC_XWAY=y
CONFIG_SPI=y
CONFIG_SPI_BITBANG=y
# CONFIG_SPI_GPIO is not set
+CONFIG_SPI_LANTIQ=y
CONFIG_SPI_MASTER=y
CONFIG_USB_SUPPORT=y
CONFIG_XZ_DEC=y
diff --git a/target/linux/lantiq/xway/profiles/003-netgear.mk b/target/linux/lantiq/xway/profiles/003-netgear.mk
new file mode 100644
index 0000000000..51a98bb2d4
--- /dev/null
+++ b/target/linux/lantiq/xway/profiles/003-netgear.mk
@@ -0,0 +1,11 @@
+define Profile/DGN3500B
+ NAME:=DGN3500B
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-leds-gpio
+endef
+
+define Profile/DGN3500B/Description
+ Netgear DGN3500B
+endef
+
+$(eval $(call Profile,DGN3500B))
+