aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/svip_le
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-07-31 18:49:54 +0000
committerJohn Crispin <john@openwrt.org>2012-07-31 18:49:54 +0000
commitf5f36911f0c398edcf87bd3190e4881c9b1b4613 (patch)
treef6b38f0bc2dc0de59875b542e2cbf162950f121b /target/linux/lantiq/svip_le
parent07c4524d33a0bbc74e0127bb37178ed3d005e905 (diff)
downloadupstream-f5f36911f0c398edcf87bd3190e4881c9b1b4613.tar.gz
upstream-f5f36911f0c398edcf87bd3190e4881c9b1b4613.tar.bz2
upstream-f5f36911f0c398edcf87bd3190e4881c9b1b4613.zip
add lantiq svip support
SVN-Revision: 32925
Diffstat (limited to 'target/linux/lantiq/svip_le')
-rw-r--r--target/linux/lantiq/svip_le/config-default35
-rw-r--r--target/linux/lantiq/svip_le/profiles/000-generic.mk8
-rw-r--r--target/linux/lantiq/svip_le/profiles/001-lantiq.mk10
-rw-r--r--target/linux/lantiq/svip_le/target.mk11
4 files changed, 64 insertions, 0 deletions
diff --git a/target/linux/lantiq/svip_le/config-default b/target/linux/lantiq/svip_le/config-default
new file mode 100644
index 0000000000..e98ec854db
--- /dev/null
+++ b/target/linux/lantiq/svip_le/config-default
@@ -0,0 +1,35 @@
+CONFIG_ADM6996_PHY=y
+CONFIG_AR8216_PHY=y
+CONFIG_CLKDEV_LOOKUP=y
+# CONFIG_CPU_LITTLE_ENDIAN is not set
+CONFIG_FSNOTIFY=y
+# CONFIG_GENERIC_PWM is not set
+CONFIG_HAVE_MACH_CLKDEV=y
+CONFIG_INPUT=y
+CONFIG_INPUT_EVDEV=y
+CONFIG_INPUT_POLLDEV=y
+CONFIG_IRQ_FORCED_THREADING=y
+# CONFIG_ISDN is not set
+CONFIG_LANTIQ_MACH_EASY33016=y
+CONFIG_LANTIQ_MACH_EASY336=y
+CONFIG_MDIO_BOARDINFO=y
+# CONFIG_PCIE_LANTIQ is not set
+# CONFIG_PCI_LANTIQ is not set
+# CONFIG_PCI_LANTIQ_NONE is not set
+CONFIG_RTL8306_PHY=y
+# CONFIG_SOC_AMAZON_SE is not set
+# CONFIG_SOC_FALCON is not set
+CONFIG_SOC_SVIP=y
+# CONFIG_SOC_TYPE_XWAY is not set
+# CONFIG_SOC_XWAY is not set
+CONFIG_SPI=y
+CONFIG_SPI_MASTER=y
+CONFIG_SPI_SVIP=y
+CONFIG_SVIP_NAT=y
+CONFIG_LANTIQ_SVIP_VIRTUAL_ETH=y
+CONFIG_LANTIQ_SVIP_ETH=y
+CONFIG_SYS_SUPPORTS_LITTLE_ENDIAN=y
+# CONFIG_USB_ARCH_HAS_EHCI is not set
+# CONFIG_USB_ARCH_HAS_OHCI is not set
+# CONFIG_USB_ARCH_HAS_XHCI is not set
+CONFIG_USB_SUPPORT=y
diff --git a/target/linux/lantiq/svip_le/profiles/000-generic.mk b/target/linux/lantiq/svip_le/profiles/000-generic.mk
new file mode 100644
index 0000000000..731e4fce5a
--- /dev/null
+++ b/target/linux/lantiq/svip_le/profiles/000-generic.mk
@@ -0,0 +1,8 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:=
+endef
+
+$(eval $(call Profile,Generic))
+
+
diff --git a/target/linux/lantiq/svip_le/profiles/001-lantiq.mk b/target/linux/lantiq/svip_le/profiles/001-lantiq.mk
new file mode 100644
index 0000000000..dd6150e126
--- /dev/null
+++ b/target/linux/lantiq/svip_le/profiles/001-lantiq.mk
@@ -0,0 +1,10 @@
+define Profile/EASY336
+ NAME:=EASY336
+ PACKAGES:=
+endef
+
+define Profile/EASY336/Description
+ Lantiq EASY336 evalkit
+endef
+
+$(eval $(call Profile,EASY336))
diff --git a/target/linux/lantiq/svip_le/target.mk b/target/linux/lantiq/svip_le/target.mk
new file mode 100644
index 0000000000..60bcfad714
--- /dev/null
+++ b/target/linux/lantiq/svip_le/target.mk
@@ -0,0 +1,11 @@
+ARCH:=mipsel
+SUBTARGET:=svip_le
+BOARDNAME:=SVIP Little Endian
+FEATURES:=squashfs jffs2
+DEVICE_TYPE:=other
+
+DEFAULT_PACKAGES+= uboot-svip hostapd-mini
+
+define Target/Description
+ Lantiq SVIP Little Endian
+endef