aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches/210-nor.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
committerJohn Crispin <john@openwrt.org>2011-03-11 08:19:53 +0000
commitc75b0ca1a8e6e9c1ffd43719792ab1903085aa93 (patch)
tree4a1a3044e0f7acb02f16849a8758e292ff66ae7d /target/linux/lantiq/patches/210-nor.patch
parent58a5102338f7fde82c0a025d99f044868c979d02 (diff)
downloadupstream-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.gz
upstream-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.tar.bz2
upstream-c75b0ca1a8e6e9c1ffd43719792ab1903085aa93.zip
* update kernel to .37 * add support for falcon (big thank you goes to lantiq !!)
SVN-Revision: 26021
Diffstat (limited to 'target/linux/lantiq/patches/210-nor.patch')
-rw-r--r--target/linux/lantiq/patches/210-nor.patch24
1 files changed, 14 insertions, 10 deletions
diff --git a/target/linux/lantiq/patches/210-nor.patch b/target/linux/lantiq/patches/210-nor.patch
index 510ac6bdf3..5c46879966 100644
--- a/target/linux/lantiq/patches/210-nor.patch
+++ b/target/linux/lantiq/patches/210-nor.patch
@@ -1,8 +1,8 @@
--- a/drivers/mtd/maps/Kconfig
+++ b/drivers/mtd/maps/Kconfig
-@@ -251,6 +251,12 @@
- help
- Support for flash chips on NETtel/SecureEdge/SnapGear boards.
+@@ -260,6 +260,12 @@
+ Support for parsing CFE image tag and creating MTD partitions on
+ Broadcom BCM63xx boards.
+config MTD_LANTIQ
+ bool "Lantiq SoC NOR support"
@@ -16,13 +16,13 @@
--- a/drivers/mtd/maps/Makefile
+++ b/drivers/mtd/maps/Makefile
@@ -59,3 +59,4 @@
- obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
-+obj-$(CONFIG_MTD_LANTIQ) += lantiq.o
+ obj-$(CONFIG_MTD_BCM963XX) += bcm963xx-flash.o
++obj-$(CONFIG_MTD_LANTIQ) += lantiq.o
--- /dev/null
+++ b/drivers/mtd/maps/lantiq.c
-@@ -0,0 +1,169 @@
+@@ -0,0 +1,173 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
@@ -48,6 +48,10 @@
+#include <lantiq.h>
+#include <lantiq_platform.h>
+
++#ifdef CONFIG_SOC_LANTIQ_XWAY
++#include <xway.h>
++#endif
++
+static map_word
+lq_read16(struct map_info *map, unsigned long adr)
+{
@@ -194,7 +198,7 @@
+MODULE_DESCRIPTION("Lantiq SoC NOR");
--- a/drivers/mtd/chips/cfi_cmdset_0001.c
+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
-@@ -41,7 +41,11 @@
+@@ -40,7 +40,11 @@
/* #define CMDSET0001_DISABLE_WRITE_SUSPEND */
// debugging, turns off buffer write mode if set to 1
@@ -207,7 +211,7 @@
/* Intel chips */
#define I82802AB 0x00ad
-@@ -1491,6 +1495,9 @@
+@@ -1493,6 +1497,9 @@
int ret=0;
adr += chip->start;
@@ -219,7 +223,7 @@
case FL_WRITING:
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -40,7 +40,11 @@
+@@ -39,7 +39,11 @@
#include <linux/mtd/xip.h>
#define AMD_BOOTLOC_BUG
@@ -232,7 +236,7 @@
#define MAX_WORD_RETRIES 3
-@@ -1156,6 +1160,10 @@
+@@ -1167,6 +1171,10 @@
adr += chip->start;