aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-12 23:06:30 +0100
committerMathias Kresin <dev@kresin.me>2018-02-20 19:25:17 +0100
commitf1d84023cb38d9159d3f5bcf290dd100ca724690 (patch)
treec61445e2c8623154bc7884e7b87629c8f43e6dcb /target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch
parent5eeaba31b8fad26d6ed0f1b52a7f156d838326b8 (diff)
downloadupstream-f1d84023cb38d9159d3f5bcf290dd100ca724690.tar.gz
upstream-f1d84023cb38d9159d3f5bcf290dd100ca724690.tar.bz2
upstream-f1d84023cb38d9159d3f5bcf290dd100ca724690.zip
lantiq: kernel 4.14: update patches and config
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch')
-rw-r--r--target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch b/target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch
index 335a1e2616..52e4cbeb1b 100644
--- a/target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch
+++ b/target/linux/lantiq/patches-4.14/0008-MIPS-lantiq-backport-old-timer-code.patch
@@ -172,9 +172,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
-@@ -1,4 +1,10 @@
--obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
-+obj-y := prom.o sysctrl.o clk.o reset.o dma.o dcdc.o
+@@ -1,3 +1,9 @@
+-obj-y := prom.o sysctrl.o clk.o dma.o gptu.o dcdc.o
++obj-y := prom.o sysctrl.o clk.o dma.o dcdc.o
+
+ifdef CONFIG_SOC_AMAZON_SE
+obj-y += gptu.o
@@ -183,10 +183,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+endif
obj-y += vmmc.o
-
--- /dev/null
+++ b/arch/mips/lantiq/xway/timer.c
-@@ -0,0 +1,845 @@
+@@ -0,0 +1,846 @@
+#ifndef CONFIG_SOC_AMAZON_SE
+
+#include <linux/kernel.h>
@@ -201,6 +200,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+#include <linux/errno.h>
+#include <linux/interrupt.h>
+#include <linux/sched.h>
++#include <linux/sched/signal.h>
+
+#include <asm/irq.h>
+#include <asm/div64.h>
@@ -880,14 +880,14 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+ int ret;
+ struct gptu_ioctl_param param;
+
-+ if (!access_ok(VERIFY_READ, arg, sizeof(struct gptu_ioctl_param)))
++ if (!access_ok(VERIFY_READ, (void __user *)arg, sizeof(struct gptu_ioctl_param)))
+ return -EFAULT;
-+ copy_from_user(&param, (void *) arg, sizeof(param));
++ copy_from_user(&param, (void __user *)arg, sizeof(param));
+
+ if ((((cmd == GPTU_REQUEST_TIMER || cmd == GPTU_SET_TIMER
+ || GPTU_SET_COUNTER) && param.timer < 2)
+ || cmd == GPTU_GET_COUNT_VALUE || cmd == GPTU_CALCULATE_DIVIDER)
-+ && !access_ok(VERIFY_WRITE, arg,
++ && !access_ok(VERIFY_WRITE, (void __user *)arg,
+ sizeof(struct gptu_ioctl_param)))
+ return -EFAULT;
+