aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-15 14:39:51 +0000
commit84da5668735a12ef1a36eeb6777c37cd0de63ef9 (patch)
tree8417e7b50ec23e10ee0678ad5b4f032260cc6b2a /target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch
parent257aff3780d895c15f710ee10edeeb9c04e97ed1 (diff)
downloadupstream-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.gz
upstream-84da5668735a12ef1a36eeb6777c37cd0de63ef9.tar.bz2
upstream-84da5668735a12ef1a36eeb6777c37cd0de63ef9.zip
kernel: update linux 3.8 to 3.8.3
Also refresh the related generic/platform patches. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36039 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch')
-rw-r--r--target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch b/target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch
index a1a70f8246..4dd94c920f 100644
--- a/target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch
+++ b/target/linux/lantiq/patches-3.8/0024-SPI-MIPS-lantiq-adds-spi-xway.patch
@@ -16,11 +16,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 986 insertions(+)
create mode 100644 drivers/spi/spi-xway.c
-diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
-index 2e188e1..3522f29 100644
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -449,6 +449,14 @@ config SPI_NUC900
+@@ -458,6 +458,14 @@ config SPI_NUC900
help
SPI driver for Nuvoton NUC900 series ARM SoCs
@@ -35,18 +33,13 @@ index 2e188e1..3522f29 100644
#
# Add new SPI master controllers in alphabetical order above this line
#
-diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
-index 64e970b..63c24da 100644
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -68,3 +68,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+@@ -69,3 +69,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-t
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
+obj-$(CONFIG_SPI_XWAY) += spi-xway.o
-diff --git a/drivers/spi/spi-xway.c b/drivers/spi/spi-xway.c
-new file mode 100644
-index 0000000..61532e3
--- /dev/null
+++ b/drivers/spi/spi-xway.c
@@ -0,0 +1,977 @@
@@ -1027,6 +1020,3 @@ index 0000000..61532e3
+MODULE_AUTHOR("Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:spi-xway");
---
-1.7.10.4
-