aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.3
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-05-27 16:02:16 +0000
committerJohn Crispin <blogic@openwrt.org>2012-05-27 16:02:16 +0000
commit9669f7a243211b155d90706ab7a49cca7beed2c6 (patch)
treecc7f4978d18a77cea569b6a6fa31c77bc1c232f7 /target/linux/lantiq/patches-3.3
parentaba80d0d041f8c225c4ddbe214c189e779b2f45e (diff)
downloadupstream-9669f7a243211b155d90706ab7a49cca7beed2c6.tar.gz
upstream-9669f7a243211b155d90706ab7a49cca7beed2c6.tar.bz2
upstream-9669f7a243211b155d90706ab7a49cca7beed2c6.zip
[lantiq] Add basic configuration for new board ZTE H201L. Still missing are button and led gpio values.
Signed-off-by: Luka Perkov <openwrt@lukaperkov.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31908 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/patches-3.3')
-rw-r--r--target/linux/lantiq/patches-3.3/206-machtypes.patch14
1 files changed, 11 insertions, 3 deletions
diff --git a/target/linux/lantiq/patches-3.3/206-machtypes.patch b/target/linux/lantiq/patches-3.3/206-machtypes.patch
index 7b891e464a..f6f24ea4b4 100644
--- a/target/linux/lantiq/patches-3.3/206-machtypes.patch
+++ b/target/linux/lantiq/patches-3.3/206-machtypes.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/lantiq/machtypes.h
+++ b/arch/mips/lantiq/machtypes.h
-@@ -20,6 +20,39 @@ enum lantiq_mach_type {
+@@ -20,6 +20,42 @@ enum lantiq_mach_type {
LANTIQ_MACH_EASY98000, /* Falcon Eval Board, NOR Flash */
LANTIQ_MACH_EASY98000SF, /* Falcon Eval Board, Serial Flash */
LANTIQ_MACH_EASY98000NAND, /* Falcon Eval Board, NAND Flash */
@@ -37,12 +37,15 @@
+
+ /* ZyXEL */
+ LANTIQ_MACH_P2601HNFX, /* ZyXEL P-2601HN-Fx */
++
++ /* ZTE */
++ LANTIQ_MACH_H201L, /* ZTE ZXV10 H201L */
};
#endif
--- a/arch/mips/lantiq/xway/Kconfig
+++ b/arch/mips/lantiq/xway/Kconfig
-@@ -6,6 +6,34 @@ config LANTIQ_MACH_EASY50712
+@@ -6,6 +6,38 @@ config LANTIQ_MACH_EASY50712
bool "Easy50712 - Danube"
default y
@@ -66,6 +69,10 @@
+ bool "P2601HNFX"
+ default y
+
++config LANTIQ_MACH_H201L
++ bool "H201L"
++ default y
++
+config LANTIQ_MACH_FRITZ_VR9
+ bool "FRITZ3370"
+ default y
@@ -79,7 +86,7 @@
choice
--- a/arch/mips/lantiq/xway/Makefile
+++ b/arch/mips/lantiq/xway/Makefile
-@@ -2,3 +2,10 @@ obj-y := sysctrl.o reset.o gpio.o gpio_s
+@@ -2,3 +2,11 @@ obj-y := sysctrl.o reset.o gpio.o gpio_s
obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
@@ -90,6 +97,7 @@
+obj-$(CONFIG_LANTIQ_MACH_NETGEAR) += mach-netgear.o
+obj-$(CONFIG_LANTIQ_MACH_WBMR) += mach-wbmr.o
+obj-$(CONFIG_LANTIQ_MACH_P2601HNFX) += mach-p2601hnfx.o
++obj-$(CONFIG_LANTIQ_MACH_H201L) += mach-h201l.o
--- a/arch/mips/lantiq/falcon/Kconfig
+++ b/arch/mips/lantiq/falcon/Kconfig
@@ -6,6 +6,14 @@ config LANTIQ_MACH_EASY98000