aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 17:13:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 17:13:24 +0000
commit0380904acb3a31738cb764407a7770bd91ff3e2b (patch)
treea08dd32b99c3bdea8647dfe79618571c82b65be7 /target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch
parent76a16170630c05175215b1e5909ad8bdc417e336 (diff)
downloadupstream-0380904acb3a31738cb764407a7770bd91ff3e2b.tar.gz
upstream-0380904acb3a31738cb764407a7770bd91ff3e2b.tar.bz2
upstream-0380904acb3a31738cb764407a7770bd91ff3e2b.zip
kernel/3.10: refresh all target patches
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38182
Diffstat (limited to 'target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch')
-rw-r--r--target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch14
1 files changed, 2 insertions, 12 deletions
diff --git a/target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch b/target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch
index 137bf4de04..9b1988fbb7 100644
--- a/target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch
+++ b/target/linux/lantiq/patches-3.10/0033-SPI-MIPS-lantiq-adds-spi-xway.patch
@@ -16,11 +16,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
3 files changed, 986 insertions(+)
create mode 100644 drivers/spi/spi-xway.c
-diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
-index 92a9345..954c19f 100644
--- a/drivers/spi/Kconfig
+++ b/drivers/spi/Kconfig
-@@ -487,6 +487,14 @@ config SPI_NUC900
+@@ -496,6 +496,14 @@ config SPI_NUC900
help
SPI driver for Nuvoton NUC900 series ARM SoCs
@@ -35,18 +33,13 @@ index 92a9345..954c19f 100644
#
# Add new SPI master controllers in alphabetical order above this line
#
-diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
-index 33f9c09..0574edf 100644
--- a/drivers/spi/Makefile
+++ b/drivers/spi/Makefile
-@@ -74,3 +74,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
+@@ -75,3 +75,4 @@ obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-t
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
obj-$(CONFIG_SPI_XCOMM) += spi-xcomm.o
obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
+obj-$(CONFIG_SPI_XWAY) += spi-xway.o
-diff --git a/drivers/spi/spi-xway.c b/drivers/spi/spi-xway.c
-new file mode 100644
-index 0000000..61532e3
--- /dev/null
+++ b/drivers/spi/spi-xway.c
@@ -0,0 +1,977 @@
@@ -1027,6 +1020,3 @@ index 0000000..61532e3
+MODULE_AUTHOR("Daniel Schwierzeck <daniel.schwierzeck@googlemail.com>");
+MODULE_LICENSE("GPL");
+MODULE_ALIAS("platform:spi-xway");
---
-1.7.10.4
-