aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
committerJohn Crispin <john@openwrt.org>2013-09-17 21:46:00 +0000
commit18b76c66fbfea0e21ff66c6df432fa109c5bbb43 (patch)
tree2569112890e70dc5dcb8fdb2c0298bd58ba9f446 /target/linux/lantiq/image
parent2b0cb17d4298c9dced24ca30c5b68ce10d64c366 (diff)
downloadupstream-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.gz
upstream-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.tar.bz2
upstream-18b76c66fbfea0e21ff66c6df432fa109c5bbb43.zip
lantiq: add a subtarget for the xrx200 SoC family
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38029
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile4
-rw-r--r--target/linux/lantiq/image/ubinize.cfg14
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e4e3e9e06b..fea32bef22 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -255,6 +255,10 @@ Image/Build/Profile/FRITZ7320=$(call Image/BuildEVA/$(1),$(1),FRITZ7320)
Image/BuildKernel/Profile/GR7000=$(call Image/BuildKernel/Template,GR7000)
Image/Build/Profile/GR7000=$(call Image/Build/$(1),$(1),GR7000)
+endif
+
+
+ifeq ($(CONFIG_TARGET_lantiq_xrx200),y)
# VR9
Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
diff --git a/target/linux/lantiq/image/ubinize.cfg b/target/linux/lantiq/image/ubinize.cfg
new file mode 100644
index 0000000000..49d55b9840
--- /dev/null
+++ b/target/linux/lantiq/image/ubinize.cfg
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+