aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-19 18:06:33 +0000
committerJohn Crispin <john@openwrt.org>2011-07-19 18:06:33 +0000
commit3833b7be24ba9f8cb847de8197e60147068afe67 (patch)
tree32fcce305db898632b66b2c41bc35243045277eb /target/linux/lantiq/image
parentfee32761f33dbd165a114d2e83eb1b101f4cb4cc (diff)
downloadupstream-3833b7be24ba9f8cb847de8197e60147068afe67.tar.gz
upstream-3833b7be24ba9f8cb847de8197e60147068afe67.tar.bz2
upstream-3833b7be24ba9f8cb847de8197e60147068afe67.zip
add support for more lantiq AR9 boards
SVN-Revision: 27694
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index f22f2c09e2..8c607b2151 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE = 64k 128k 256k
-ase_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
+ase_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
xway_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
falcon_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
@@ -199,6 +199,14 @@ endef
endif
ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/WBMR
+ $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/WBMR
+ $(call Image/Build/$(1),$(1),WBMR)
+endef
+
define Image/BuildKernel/Profile/DGN3500B
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
endef
@@ -208,11 +216,13 @@ define Image/Build/Profile/DGN3500B
endef
define Image/BuildKernel/Profile/Generic
+ $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
$(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
$(call Image/BuildKernel/Template,NONE)
endef
define Image/Build/Profile/Generic
+ $(call Image/Build/$(1),$(1),WBMR)
$(call Image/Build/$(1),$(1),DGN3500B)
$(call Image/Build/$(1),$(1),NONE)
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs