aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image
diff options
context:
space:
mode:
authorLuis Araneda <luaraneda@gmail.com>2017-12-10 19:45:20 -0300
committerMathias Kresin <dev@kresin.me>2017-12-12 18:47:26 +0100
commit575178e4628cf32b97feec66c4a9726b4f30fa88 (patch)
treea0b4f3d5385222b9ce20ebbda645af3addf01980 /target/linux/lantiq/image
parent72051f70368b53afa3305e1485c62b7e47fc1210 (diff)
downloadupstream-575178e4628cf32b97feec66c4a9726b4f30fa88.tar.gz
upstream-575178e4628cf32b97feec66c4a9726b4f30fa88.tar.bz2
upstream-575178e4628cf32b97feec66c4a9726b4f30fa88.zip
treewide: add only one device when appending to TARGET_DEVICES
This will avoid some conflicts when doing a git rebase or merge, specially when adding support to a new device. Signed-off-by: Luis Araneda <luaraneda@gmail.com> [drop brcm47xx changes which rename the images] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image')
-rw-r--r--target/linux/lantiq/image/tp-link.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index 5bbc18a852..f674ba298f 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -21,6 +21,7 @@ define Device/TDW8970
DEVICE_TITLE := TP-LINK TD-W8970
DEVICE_PACKAGES:= kmod-ath9k wpad-mini kmod-usb-dwc2 kmod-usb-ledtrig-usbport
endef
+TARGET_DEVICES += TDW8970
define Device/TDW8980
$(Device/lantiqTpLink)
@@ -32,6 +33,7 @@ define Device/TDW8980
DEVICE_TITLE := TP-LINK TD-W8980
DEVICE_PACKAGES:= kmod-ath9k kmod-owl-loader wpad-mini kmod-usb-dwc2 kmod-usb-ledtrig-usbport
endef
+TARGET_DEVICES += TDW8980
define Device/VR200v
$(Device/lantiqTpLink)
@@ -44,5 +46,5 @@ define Device/VR200v
DEVICE_TITLE := TP-LINK Archer VR200v
DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += TDW8970 TDW8980 VR200v
+TARGET_DEVICES += VR200v