aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2021-11-13 14:55:13 +0100
committerMathias Kresin <dev@kresin.me>2021-11-27 21:40:12 +0100
commita328b6831c0f1e47e4fd4da4e00c0b9cb53cf2e4 (patch)
tree003835e1580801039a0a1f1be1566956fbf18643 /target/linux/lantiq/image/lzma-loader/Makefile
parent1404ed25b8f4963da148f1da2e561ecde7a34df6 (diff)
downloadupstream-a328b6831c0f1e47e4fd4da4e00c0b9cb53cf2e4.tar.gz
upstream-a328b6831c0f1e47e4fd4da4e00c0b9cb53cf2e4.tar.bz2
upstream-a328b6831c0f1e47e4fd4da4e00c0b9cb53cf2e4.zip
lantiq: bring back okli loader
Removed due to being unused with 1f7a03a70603, but now required for the ar7 FRITZ!Box. Could be used for the ARV7519RW22 as well, for which the image generation was disabled due to a stock u-boot issue with kernel bigger than 2 MByte. The code is combination of the ath79 and ramips okli loader. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/lzma-loader/Makefile')
-rw-r--r--target/linux/lantiq/image/lzma-loader/Makefile72
1 files changed, 72 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/lzma-loader/Makefile b/target/linux/lantiq/image/lzma-loader/Makefile
new file mode 100644
index 0000000000..b455e6f63d
--- /dev/null
+++ b/target/linux/lantiq/image/lzma-loader/Makefile
@@ -0,0 +1,72 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+LZMA_TEXT_START :=
+LOADADDR :=
+LOADER := loader.bin
+LOADER_NAME := $(basename $(notdir $(LOADER)))
+LOADER_DATA :=
+KERNEL_MAGIC :=
+TARGET_DIR :=
+FLASH_START :=
+FLASH_OFFS :=
+FLASH_MAX :=
+BOARD :=
+PLATFORM :=
+
+ifeq ($(TARGET_DIR),)
+TARGET_DIR := $(KDIR)
+endif
+
+LOADER_BIN := $(TARGET_DIR)/$(LOADER_NAME).bin
+LOADER_GZ := $(TARGET_DIR)/$(LOADER_NAME).gz
+LOADER_ELF := $(TARGET_DIR)/$(LOADER_NAME).elf
+
+PKG_NAME := lzma-loader
+PKG_BUILD_DIR := $(KDIR)/$(PKG_NAME)
+
+.PHONY : loader-compile loader.bin loader.elf loader.gz
+
+$(PKG_BUILD_DIR)/.prepared:
+ mkdir $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+ touch $@
+
+loader-compile: $(PKG_BUILD_DIR)/.prepared
+ $(MAKE) -C $(PKG_BUILD_DIR) CROSS_COMPILE="$(TARGET_CROSS)" \
+ LZMA_TEXT_START=$(LZMA_TEXT_START) \
+ LOADADDR=$(LOADADDR) \
+ LOADER_DATA=$(LOADER_DATA) \
+ KERNEL_MAGIC=$(KERNEL_MAGIC) \
+ FLASH_START=$(FLASH_START) \
+ FLASH_OFFS=$(FLASH_OFFS) \
+ FLASH_MAX=$(FLASH_MAX) \
+ BOARD="$(BOARD)" \
+ PLATFORM="$(PLATFORM)" \
+ clean all
+
+loader.gz: $(PKG_BUILD_DIR)/loader.bin
+ gzip -nc9 $< > $(LOADER_GZ)
+
+loader.elf: $(PKG_BUILD_DIR)/loader.elf
+ $(CP) $< $(LOADER_ELF)
+
+loader.bin: $(PKG_BUILD_DIR)/loader.bin
+ $(CP) $< $(LOADER_BIN)
+
+download:
+prepare: $(PKG_BUILD_DIR)/.prepared
+compile: loader-compile
+
+install:
+
+clean:
+ rm -rf $(PKG_BUILD_DIR)
+