aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/danube.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2021-02-16 19:35:01 +0100
committerMathias Kresin <dev@kresin.me>2021-03-01 00:19:58 +0100
commit23dd7867347ab4fd88592d0bfec1ce5a959c09f3 (patch)
tree2629ac052d75c5de03e914f05f7190418ba76d40 /target/linux/lantiq/image/danube.mk
parent7995a937447221a757ca8a0330a46944eacff473 (diff)
downloadupstream-23dd7867347ab4fd88592d0bfec1ce5a959c09f3.tar.gz
upstream-23dd7867347ab4fd88592d0bfec1ce5a959c09f3.tar.bz2
upstream-23dd7867347ab4fd88592d0bfec1ce5a959c09f3.zip
lantiq: set maximum kernel size
These boards have a fixed size kernel partition but do not limit the kernel size during image building. Disable image building for both boards as well, since the kernel of the last release as well as master are to big to fit into the 2 MByte kernel partition. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/danube.mk')
-rw-r--r--target/linux/lantiq/image/danube.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/danube.mk b/target/linux/lantiq/image/danube.mk
index ea22081d65..73ec27222a 100644
--- a/target/linux/lantiq/image/danube.mk
+++ b/target/linux/lantiq/image/danube.mk
@@ -188,6 +188,7 @@ define Device/bt_homehub-v2b
DEVICE_VARIANT := Type B
BOARD_NAME := BTHOMEHUBV2B
SOC := danube
+ KERNEL_SIZE := 2048k
DEVICE_PACKAGES := kmod-usb-dwc2 \
kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
kmod-ltq-adsl-danube-fw-a kmod-ltq-atm-danube \
@@ -195,6 +196,7 @@ define Device/bt_homehub-v2b
ltq-adsl-app ppp-mod-pppoa \
kmod-ath9k kmod-owl-loader wpad-basic-wolfssl
SUPPORTED_DEVICES += BTHOMEHUBV2B
+ DEFAULT := n
endef
TARGET_DEVICES += bt_homehub-v2b