aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/ar9.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2021-11-14 21:53:45 +0100
committerMathias Kresin <dev@kresin.me>2021-11-27 21:40:12 +0100
commit9764968bbac00a1b8a99ef22f24f1a3c25e76f9d (patch)
tree11e3572c2699d4c4706ec5be783a1225cc68ff56 /target/linux/lantiq/image/ar9.mk
parenta328b6831c0f1e47e4fd4da4e00c0b9cb53cf2e4 (diff)
downloadupstream-9764968bbac00a1b8a99ef22f24f1a3c25e76f9d.tar.gz
upstream-9764968bbac00a1b8a99ef22f24f1a3c25e76f9d.tar.bz2
upstream-9764968bbac00a1b8a99ef22f24f1a3c25e76f9d.zip
lantiq: ar7: use okli loader for FRITZ!Box
With Kernel 5.10 the ar7 FRITZ!Box are not booting the initramfs nor the sysupgrade image any more. Presumably due to the grown kernel. Use the okli preloader to workaround the bootloader issue. No solution so far for the initramfs. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/ar9.mk')
-rw-r--r--target/linux/lantiq/image/ar9.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/ar9.mk b/target/linux/lantiq/image/ar9.mk
index a68868f0d9..5a17395f82 100644
--- a/target/linux/lantiq/image/ar9.mk
+++ b/target/linux/lantiq/image/ar9.mk
@@ -1,8 +1,9 @@
define Device/avm_fritz7312
- $(Device/AVM)
+ $(Device/AVM_preloader)
DEVICE_MODEL := FRITZ!Box 7312
SOC := ar9
IMAGE_SIZE := 15744k
+ LOADER_FLASH_OFFS := 0x31000
DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic-wolfssl \
kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
@@ -12,12 +13,13 @@ endef
TARGET_DEVICES += avm_fritz7312
define Device/avm_fritz7320
- $(Device/AVM)
+ $(Device/AVM_preloader)
DEVICE_MODEL := FRITZ!Box 7320
DEVICE_ALT0_VENDOR := 1&1
DEVICE_ALT0_MODEL := HomeServer
SOC := ar9
IMAGE_SIZE := 15744k
+ LOADER_FLASH_OFFS := 0x31000
DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic-wolfssl \
kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \