aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-31 12:11:57 +0100
committerMathias Kresin <dev@kresin.me>2018-02-20 19:25:17 +0100
commitf8a6987cd1aae8698062c8ac3907193a5c66004a (patch)
tree463163f57066c00677b5432ef4ff163b58b3e108 /target/linux/lantiq/image/Makefile
parent627a28eb09c0aa3471466850dfde6a063481a4f6 (diff)
downloadupstream-f8a6987cd1aae8698062c8ac3907193a5c66004a.tar.gz
upstream-f8a6987cd1aae8698062c8ac3907193a5c66004a.tar.bz2
upstream-f8a6987cd1aae8698062c8ac3907193a5c66004a.zip
lantiq: make dts files and kernel config kernel version specific
Move the devicetree source files to a kernel specific directory in preparation of adding kernel 4.14 support. Rename the subtarget kernel config files to match a specific kernel version. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 2e8eccf5ac..e52e43c6e5 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -55,12 +55,11 @@ endef
# Shared device definition: applies to every defined device
define Device/Default
PROFILES = Default
- KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
+ KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs
KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
FILESYSTEMS := squashfs
- DEVICE_DTS_DIR := ../dts
IMAGE_SIZE :=
SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
IMAGES := sysupgrade.bin