aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-03-30 10:02:30 +0000
committerJohn Crispin <john@openwrt.org>2014-03-30 10:02:30 +0000
commite36568e74b406f5c718904b330fcc7cb34ab2a17 (patch)
tree7b0a91eb996ecdf02e3a8e07d6ec558ea3b12970 /target/linux/lantiq/image/Makefile
parent42e8cb6388a7f9bfd8ff820a5af9193e8fb67fa8 (diff)
downloadupstream-e36568e74b406f5c718904b330fcc7cb34ab2a17.tar.gz
upstream-e36568e74b406f5c718904b330fcc7cb34ab2a17.tar.bz2
upstream-e36568e74b406f5c718904b330fcc7cb34ab2a17.zip
lntiq: add support for Astoria ARV7519RW.
These patches add support for the Astoria ARV7519RW aka Livebox 2.1 The PCI and PCIe interfaces have been disabled. Also, because there are two revisions of this board with different GPHY firmwares, two targets were defined. V2: rewrote partitions to work with an u-boot specifically made for these boards. Signed off by: Esteban Benito <estebanjbs@gmail.com> Signed off by: Carles Gadea <carlesgrg@gmail.com> Tested by: José Vázquez Fernández <ppvazquezfer@gmail.com> SVN-Revision: 40329
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index cd36d12ca1..28cb96c8b7 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -307,6 +307,12 @@ Image/Build/Profile/H201L=$(call Image/Build/$(1),$(1),H201L)
Image/BuildKernel/Profile/P2601HNFX=$(call Image/BuildKernel/Template,P2601HNFX)
Image/Build/Profile/P2601HNFX=$(call Image/Build/$(1),$(1),P2601HNFX)
+Image/BuildKernel/Profile/ARV7519RWV11=$(call Image/BuildKernel/Template,ARV7519RWV11,$(1))
+Image/Build/Profile/ARV7519RWV11=$(call Image/Build/$(1), $(1),ARV7519RWV11)
+
+Image/BuildKernel/Profile/ARV7519RWV12=$(call Image/BuildKernel/Template,ARV7519RWV12,$(1))
+Image/Build/Profile/ARV7519RWV12=$(call Image/Build/$(1), $(1),ARV7519RWV12)
+
endif