aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-17 11:41:08 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-19 11:24:10 +0100
commitbe296745f82665272771e1cfeb2c19438cf3cb5a (patch)
tree8904cb4e3b396f7dd0c2e5dcec40e1f056862ed4 /target/linux/lantiq/image/Makefile
parent9d6d7d9a0e1f8e516537d80c222ce8f787070280 (diff)
downloadupstream-be296745f82665272771e1cfeb2c19438cf3cb5a.tar.gz
upstream-be296745f82665272771e1cfeb2c19438cf3cb5a.tar.bz2
upstream-be296745f82665272771e1cfeb2c19438cf3cb5a.zip
lantiq: append metadata to images
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 3064e2b25c..83b57be7e8 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -64,8 +64,9 @@ define Device/Default
DEVICE_DTS := $(1)
DEVICE_DTS_DIR := ../dts
IMAGE_SIZE :=
+ SUPPORTED_DEVICES = $$(DEVICE_DTS)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
endef
DEVICE_VARS += IMAGE_SIZE
@@ -85,7 +86,7 @@ endef
define Device/NAND
$(Device/NAND/$(SUBTARGET))
- IMAGE/sysupgrade.bin := sysupgrade-tar
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
endef
define Device/lantiqBrnImage
@@ -358,10 +359,10 @@ define Device/DGN3500
factory-NA.bin factory-WW.bin
IMAGE/sysupgrade-NA.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "NA" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
IMAGE/sysupgrade-WW.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "WW" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
IMAGE/factory-NA.bin := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "NA" | pad-rootfs | \
@@ -385,7 +386,7 @@ define Device/DGN3500B
IMAGES += factory.bin
IMAGE/sysupgrade.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "DE" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
IMAGE/factory.bin := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "DE" | pad-rootfs | \