aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-19 14:18:46 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-19 14:19:27 +0100
commit77382273211022eb6546dbbdcf4a4b4dd9d40e7f (patch)
tree1c0a498e1c22045e09bbc594d868a0dab03c2363 /target/linux/lantiq/image/Makefile
parent81e3c022e017be76d4f3eaf67cfd7ddba09e85be (diff)
downloadupstream-77382273211022eb6546dbbdcf4a4b4dd9d40e7f.tar.gz
upstream-77382273211022eb6546dbbdcf4a4b4dd9d40e7f.tar.bz2
upstream-77382273211022eb6546dbbdcf4a4b4dd9d40e7f.zip
lantiq: run append-metadata before check-size to fix build errors
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 83b57be7e8..018d44eb0a 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -66,7 +66,7 @@ define Device/Default
IMAGE_SIZE :=
SUPPORTED_DEVICES = $$(DEVICE_DTS)
IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
DEVICE_VARS += IMAGE_SIZE
@@ -359,10 +359,10 @@ define Device/DGN3500
factory-NA.bin factory-WW.bin
IMAGE/sysupgrade-NA.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "NA" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
+ pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade-WW.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "WW" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
+ pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory-NA.bin := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "NA" | pad-rootfs | \
@@ -386,7 +386,7 @@ define Device/DGN3500B
IMAGES += factory.bin
IMAGE/sysupgrade.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "DE" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE) | append-metadata
+ pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "DE" | pad-rootfs | \