aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:38:53 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-24 18:38:53 +0100
commit09ee51c614d95904010f3646938b5b85c73bebec (patch)
tree5153742aab109ab81bb49fbb2386d903b019c6c4 /target/linux/lantiq/image/Makefile
parentd9a0794f8d56236b2984c15948d93aa5d320e16e (diff)
downloadupstream-09ee51c614d95904010f3646938b5b85c73bebec.tar.gz
upstream-09ee51c614d95904010f3646938b5b85c73bebec.tar.bz2
upstream-09ee51c614d95904010f3646938b5b85c73bebec.zip
lantiq: define SOC only once for uniform targets
In lantiq there are several subtarget where all devices have the same value set to the SOC variable for each device individually. This patch introduces a non-device-dependent variable DEFAULT_SOC, which is used if no specific SOC is set for a device, and thus reduces the number of redundant definitions drastically. This is applied to all subtargets except xway, as only the latter has two different SOCs. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 68de191283..d385cdca7b 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -111,10 +111,12 @@ define Device/AVM
endef
ifeq ($(SUBTARGET),ase)
+DEFAULT_SOC := amazonse
include amazonse.mk
endif
ifeq ($(SUBTARGET),xway_legacy)
+DEFAULT_SOC := danube
include xway_legacy.mk
endif
@@ -125,12 +127,14 @@ endif
ifeq ($(SUBTARGET),xrx200)
+DEFAULT_SOC := vr9
include tp-link.mk
include vr9.mk
endif
ifeq ($(SUBTARGET),falcon)
+DEFAULT_SOC := falcon
include falcon.mk
endif