aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-06-28 23:36:37 +0200
committerMathias Kresin <dev@kresin.me>2017-07-04 16:29:01 +0200
commit08c499f865a1a42ed50e70c8ff68b9916a5033f1 (patch)
tree7d3324275b8c2eba4ecb95fced62e9d8247674e2 /target/linux/lantiq/image/Makefile
parenta3d232e1e6e5a49e7d1c1d9bc56be9ebd8ae6171 (diff)
downloadupstream-08c499f865a1a42ed50e70c8ff68b9916a5033f1.tar.gz
upstream-08c499f865a1a42ed50e70c8ff68b9916a5033f1.tar.bz2
upstream-08c499f865a1a42ed50e70c8ff68b9916a5033f1.zip
lantiq: use img file extension for DGN3500 factory images
The Netgear UI in basic mode refuses the upgrade file if the the fileextension is not img. The expert/advanced mode accepts any fileextension. Use img to make it work in any case. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e0f58af3e2..122a8a5898 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -366,18 +366,18 @@ define Device/DGN3500
IMAGE_SIZE := 16000k
IMAGES := \
sysupgrade-NA.bin sysupgrade-WW.bin \
- factory-NA.bin factory-WW.bin
+ factory-NA.img factory-WW.img
IMAGE/sysupgrade-NA.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "NA" | \
pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/sysupgrade-WW.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "WW" | \
pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory-NA.bin := \
+ IMAGE/factory-NA.img := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "NA" | pad-rootfs | \
check-size 16320k | pad-to 16384k
- IMAGE/factory-WW.bin := \
+ IMAGE/factory-WW.img := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "WW" | pad-rootfs | \
check-size 16320k | pad-to 16384k
@@ -393,11 +393,11 @@ TARGET_DEVICES += DGN3500
define Device/DGN3500B
IMAGE_SIZE := 16000k
- IMAGES += factory.bin
+ IMAGES += factory.img
IMAGE/sysupgrade.bin := \
append-kernel | append-rootfs | dgn3500-sercom-footer 0x0 "DE" | \
pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := \
+ IMAGE/factory.img := \
pad-extra $(DGN3500_KERNEL_OFFSET_DEC) | append-kernel | append-rootfs | \
dgn3500-sercom-footer $(DGN3500_KERNEL_OFFSET_HEX) "DE" | pad-rootfs | \
check-size 16320k | pad-to 16384k