aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 09:16:06 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 09:16:06 +0000
commit4a3d655e10c04e166bcafd34c34365ee46fa2d31 (patch)
tree586217c67fc2cf28506b928862ab75cb2a0b14cd /target/linux/lantiq/image/Makefile
parent8f230ce46475e7e11e81a188e7b14f963f4c26bb (diff)
downloadupstream-4a3d655e10c04e166bcafd34c34365ee46fa2d31.tar.gz
upstream-4a3d655e10c04e166bcafd34c34365ee46fa2d31.tar.bz2
upstream-4a3d655e10c04e166bcafd34c34365ee46fa2d31.zip
lantiq: add support for ZyXEL P2812HNUFX
This patch adds almost full support for this board. WiFi is still not working. The FXS ports are not functional due to missing support for the TAPI driver on VR9 SoC. Signed-off-by: Antonios Vamporakis <ant@area128.com> Tested-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 98f82369b1..4550fc4619 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -310,6 +310,10 @@ endif
ifeq ($(CONFIG_TARGET_lantiq_xrx200),y)
# VR9
+Image/BuildKernel/Profile/P2812HNUFX=$(call Image/BuildKernel/Template,P2812HNUFX)
+Image/InstallKernel/Template/P2812HNUFX=$(call Image/InstallKernel/Template,P2812HNUFX)
+Image/Build/Profile/P2812HNUFX=$(call Image/Build/$(1),$(1),P2812HNUFX)
+
Image/BuildKernel/Profile/EASY80920NAND=$(call Image/BuildKernel/Template,EASY80920NAND)
Image/Build/Profile/EASY80920NAND=$(call Image/Build/$(1),$(1),EASY80920NAND)