aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-11-09 19:26:43 +0000
committerJohn Crispin <blogic@openwrt.org>2012-11-09 19:26:43 +0000
commit3a08b051849c0a7534fbe79e1ea525a566c5fd24 (patch)
treecdc5eaa54a163e8dd21bd141c136311808d9e6dd /target/linux/lantiq/image/Makefile
parentc27f32609a7c6a9a3d76c773270187741ef72ab8 (diff)
downloadupstream-3a08b051849c0a7534fbe79e1ea525a566c5fd24.tar.gz
upstream-3a08b051849c0a7534fbe79e1ea525a566c5fd24.tar.bz2
upstream-3a08b051849c0a7534fbe79e1ea525a566c5fd24.zip
[lantiq] a few more dts files (WIP)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34130 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/image/Makefile')
-rw-r--r--target/linux/lantiq/image/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 11374ef945..ef289823dd 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -21,7 +21,7 @@ endef
define PatchKernelLzma
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(1)
-ifeq ($(CONFIG_LINUX_3_5),y)
+ifeq ($(CONFIG_LINUX_3_6),y)
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(KDIR)/$(1).dtb ./$(1).dts
$(STAGING_DIR_HOST)/bin/patch-dtb $(KDIR)/vmlinux-$(1) $(KDIR)/$(1).dtb
else
@@ -202,14 +202,25 @@ endif
ifeq ($(CONFIG_TARGET_lantiq_xway),y)
+# VR9
Image/BuildKernel/Profile/EASY80920-NAND=$(call Image/BuildKernel/Template,EASY80920-NAND)
Image/Build/Profile/EASY80920-NAND=$(call Image/Build/$(1),$(1),EASY80920-NAND)
Image/BuildKernel/Profile/EASY80920-NOR=$(call Image/BuildKernel/Template,EASY80920-NOR)
Image/Build/Profile/EASY80920-NOR=$(call Image/Build/$(1),$(1),EASY80920-NOR)
+# Danube
Image/BuildKernel/Profile/ARV7525PW=$(call Image/BuildKernel/Template,ARV7525PW)
Image/Build/Profile/ARV7525PW=$(call Image/Build/$(1),$(1),ARV7525PW)
+Image/BuildKernel/Profile/ARV4520PW=$(call Image/BuildKernel/Template,ARV4520PW)
+Image/Build/Profile/ARV4520PW=$(call Image/Build/$(1),$(1),ARV4520PW)
+
+Image/BuildKernel/Profile/ARV752DPW=$(call Image/BuildKernel/Template,ARV752DPW)
+Image/Build/Profile/ARV752DPW=$(call Image/Build/$(1),$(1),ARV752DPW)
+
+Image/BuildKernel/Profile/ARV752DPW22=$(call Image/BuildKernel/Template,ARV752DPW22)
+Image/Build/Profile/ARV752DPW22=$(call Image/Build/$(1),$(1),ARV752DPW22)
+
endif
ifeq ($(CONFIG_TARGET_lantiq_vr9),y)