aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/falcon
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2016-10-02 18:39:50 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2016-11-27 17:40:20 +0100
commit93715427835e747f0e0b348c8a3ce91dd68ef4f9 (patch)
treee16da2bf547e204e6a929324b405aea71281857e /target/linux/lantiq/falcon
parent5cdbc8632962a4e4451db771597cf84e1c5046d5 (diff)
downloadupstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.tar.gz
upstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.tar.bz2
upstream-93715427835e747f0e0b348c8a3ce91dd68ef4f9.zip
lantiq: add Falcon support
This adds support for the Intel Falcon SoC for GPON. Support for the Falcon SoC was removed in commit c8218363951 svn rev: 40392 from OpenWrt, this commit adds it again. This patch adds a new subtarget for the Falcon SoC, but it still misses all the drivers needed to control the GPON part. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/lantiq/falcon')
-rw-r--r--target/linux/lantiq/falcon/config-default10
-rw-r--r--target/linux/lantiq/falcon/profiles/00-default.mk9
-rw-r--r--target/linux/lantiq/falcon/target.mk13
3 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/lantiq/falcon/config-default b/target/linux/lantiq/falcon/config-default
new file mode 100644
index 0000000000..de4fa3686d
--- /dev/null
+++ b/target/linux/lantiq/falcon/config-default
@@ -0,0 +1,10 @@
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_SPLIT_FIRMWARE_NAME="linux"
+CONFIG_PINCTRL_FALCON=y
+# CONFIG_PSB6970_PHY is not set
+# CONFIG_RTL8366_SMI is not set
+CONFIG_SOC_FALCON=y
+# CONFIG_SOC_TYPE_XWAY is not set
+# CONFIG_SOC_XWAY is not set
+CONFIG_SPI_FALCON=y
diff --git a/target/linux/lantiq/falcon/profiles/00-default.mk b/target/linux/lantiq/falcon/profiles/00-default.mk
new file mode 100644
index 0000000000..26bc8b502b
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/00-default.mk
@@ -0,0 +1,9 @@
+define Profile/Default
+ NAME:=Default Profile
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/lantiq/falcon/target.mk b/target/linux/lantiq/falcon/target.mk
new file mode 100644
index 0000000000..b87d1dc1b3
--- /dev/null
+++ b/target/linux/lantiq/falcon/target.mk
@@ -0,0 +1,13 @@
+ARCH:=mips
+SUBTARGET:=falcon
+BOARDNAME:=Falcon
+FEATURES:=squashfs mips16 nand
+CPU_TYPE:=24kc
+
+DEFAULT_PACKAGES+= kmod-leds-gpio \
+ kmod-gpio-button-hotplug \
+ kmod-ledtrig-heartbeat
+
+define Target/Description
+ Lantiq Falcon
+endef