aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-12-27 20:44:11 -0800
committerPaul Spooren <mail@aparcar.org>2023-02-04 02:35:03 +0100
commit2630e5063df0240eb0d05cd6e953b2bd412e3215 (patch)
treec420021efd2ad444bf7e4f9e83675fdd43ae483e /target/linux/kirkwood
parent19988b66d07f44be757c4a0e41be899dbf8c72dd (diff)
downloadupstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.gz
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.tar.bz2
upstream-2630e5063df0240eb0d05cd6e953b2bd412e3215.zip
treewide: replace wpad-basic-wolfssl default
The newly merged mbedtls backend is smaller and has fewer ABI related issues than the wolfSSL one. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 60e8654ad3..ea76e21970 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -93,7 +93,7 @@ define Device/checkpoint_l-50
DEVICE_VENDOR := Check Point
DEVICE_MODEL := L-50
DEVICE_PACKAGES := kmod-ath9k kmod-gpio-button-hotplug kmod-mvsdio \
- kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic-wolfssl
+ kmod-rtc-s35390a kmod-usb-ledtrig-usbport wpad-basic-mbedtls
IMAGES := sysupgrade.bin
endef
TARGET_DEVICES += checkpoint_l-50
@@ -145,7 +145,7 @@ define Device/endian_4i-edge-200
DEVICE_MODEL := 4i Edge 200
DEVICE_ALT0_VENDOR := Endian
DEVICE_ALT0_MODEL := UTM Mini Firewall
- DEVICE_PACKAGES := kmod-ath9k kmod-mvsdio wpad-basic-wolfssl
+ DEVICE_PACKAGES := kmod-ath9k kmod-mvsdio wpad-basic-mbedtls
KERNEL_SIZE := 4096k
IMAGES := sysupgrade.bin
endef
@@ -201,7 +201,7 @@ TARGET_DEVICES += iptime_nas1
define Device/linksys
DEVICE_VENDOR := Linksys
- DEVICE_PACKAGES := kmod-mwl8k wpad-basic-wolfssl kmod-gpio-button-hotplug
+ DEVICE_PACKAGES := kmod-mwl8k wpad-basic-mbedtls kmod-gpio-button-hotplug
KERNEL_IN_UBI :=
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi