aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-28 00:25:41 +0100
committerMathias Kresin <dev@kresin.me>2018-01-09 22:06:54 +0100
commitd2e18dae2892b5779226b75d49aa7e6078835ffe (patch)
tree6013486aa778860eb4a95890f5158e767a3040bc /target/linux/kirkwood
parentf0227af5d6f46c910762a9df5f4de41d6a9ccd53 (diff)
downloadupstream-d2e18dae2892b5779226b75d49aa7e6078835ffe.tar.gz
upstream-d2e18dae2892b5779226b75d49aa7e6078835ffe.tar.bz2
upstream-d2e18dae2892b5779226b75d49aa7e6078835ffe.zip
kirkwood: cleanup image build code
Drop NAND_BLOCKSIZE, UBI_OPTS and UBIFS_OPTS. They are either used by not supported filesystems or by the legacy image build code. Add common used options/images to the default build code and override the options where necessary. Don't export the kernel image, it isn't required by any board. While at it, change the file extension for the sysupgrade images to bin. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile34
1 files changed, 8 insertions, 26 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 77ef896796..f52ae7de01 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -5,50 +5,40 @@
# See /LICENSE for more information.
#
-NAND_BLOCKSIZE := 2048-128k
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
KERNEL_LOADADDR:=0x8000
-UBI_OPTS := -m 2048 -p 128KiB -s 512
-UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
-
define Device/Default
PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
KERNEL_SUFFIX := -uImage
- KERNEL_INSTALL := 1
+ KERNEL_IN_UBI := 1
PAGESIZE := 2048
SUBPAGESIZE := 512
BLOCKSIZE := 128k
- IMAGES := sysupgrade.tar
- IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := sysupgrade-tar
+ IMAGE/factory.bin := append-ubi
endef
define Device/dockstar
DEVICE_DTS := kirkwood-dockstar
- FILESYSTEMS := squashfs
DEVICE_TITLE := Seagate FreeAgent Dockstar
- IMAGES += factory.bin
- IMAGE/factory.bin := append-ubi
- KERNEL_IN_UBI := 1
endef
TARGET_DEVICES += dockstar
define Device/goflexnet
-$(Device/dockstar)
DEVICE_TITLE := Seagate GoFlexNet
DEVICE_DTS := kirkwood-goflexnet
endef
TARGET_DEVICES += goflexnet
define Device/goflexhome
-$(Device/dockstar)
DEVICE_TITLE := Seagate GoFlexHome
DEVICE_DTS := kirkwood-goflexhome
endef
@@ -59,8 +49,7 @@ define Device/linksys-audi
DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
DEVICE_DTS := kirkwood-linksys-audi
KERNEL_SIZE := 2624k
- FILESYSTEMS := squashfs
- IMAGES += factory.bin
+ KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
@@ -71,22 +60,19 @@ define Device/linksys-viper
DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
DEVICE_DTS := kirkwood-linksys-viper
KERNEL_SIZE := 2688k
- FILESYSTEMS := squashfs
- IMAGES += factory.bin
+ KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
TARGET_DEVICES += linksys-viper
define Device/iconnect
-$(Device/dockstar)
DEVICE_TITLE := Iomega Iconnect
DEVICE_DTS := kirkwood-iconnect
endef
TARGET_DEVICES += iconnect
define Device/nsa310b
-$(Device/dockstar)
DEVICE_TITLE := ZyXEL NSA310b
DEVICE_DTS := kirkwood-nsa310b
DEVICE_PACKAGES := kmod-r8169 kmod-gpio-button-hotplug kmod-hwmon-lm85
@@ -94,7 +80,6 @@ endef
TARGET_DEVICES += nsa310b
define Device/nsa325
-$(Device/dockstar)
DEVICE_TITLE := ZyXEL NSA325 (v1 and v2)
DEVICE_DTS := kirkwood-nsa325
DEVICE_PACKAGES := kmod-gpio-button-hotplug kmod-rtc-pcf8563 kmod-usb3
@@ -104,24 +89,21 @@ TARGET_DEVICES += nsa325
define Device/on100
DEVICE_TITLE := Cisco Systems ON100
DEVICE_DTS := kirkwood-on100
-# DEVICE_PACKAGES := kmod-mvsdio kmod-usb-storage kmod-i2c-core kmod-i2c-mv64xxx kmod-ata-core kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio
DEVICE_PACKAGES := kmod-i2c-mv64xxx
KERNEL_SIZE := 5376k
- IMAGES += factory.bin
- IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
+ KERNEL_IN_UBI := 0
UBINIZE_OPTS := -E 5
+ IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
TARGET_DEVICES += on100
define Device/pogo_e02
-$(Device/dockstar)
DEVICE_TITLE := Cloud Engines Pogoplug E02
DEVICE_DTS := kirkwood-pogo_e02
endef
TARGET_DEVICES += pogo_e02
define Device/ib62x0
-$(Device/dockstar)
DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
DEVICE_DTS := kirkwood-ib62x0
endef