aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 17:26:27 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-24 09:40:46 +0100
commit49e81f9fe4bc6f060a74f5505eca2a1767058b0b (patch)
tree6fd55c3c79d0ca32bc410a376abc26344c845942 /target/linux/kirkwood
parent9a1f441ac81c0c2b96ec813a645bae4fc8792bf5 (diff)
downloadupstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.tar.gz
upstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.tar.bz2
upstream-49e81f9fe4bc6f060a74f5505eca2a1767058b0b.zip
kirkwood: clean up profiles, move to image makefile
Adds support for per-device rootfs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/kirkwood')
-rw-r--r--target/linux/kirkwood/image/Makefile19
-rw-r--r--target/linux/kirkwood/profiles/00-default.mk17
-rw-r--r--target/linux/kirkwood/profiles/100-generic.mk22
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk108
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk32
-rw-r--r--target/linux/kirkwood/profiles/120-plug.mk64
6 files changed, 28 insertions, 234 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 383689d469..2c4ad208f2 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -17,6 +17,7 @@ UBI_OPTS := -m 2048 -p 128KiB -s 512
UBIFS_OPTS := -m 2048 -e 126KiB -c 4096
define Device/Default
+ PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
KERNEL := kernel-bin | append-dtb | uImage none
KERNEL_NAME := zImage
@@ -34,7 +35,7 @@ endef
define Device/dockstar
DEVICE_DTS := kirkwood-dockstar
FILESYSTEMS := squashfs
- PROFILES := Generic DOCKSTAR
+ DEVICE_TITLE := Seagate FreeAgent Dockstar
IMAGES += factory.bin
IMAGE/factory.bin := append-ubi
KERNEL_IN_UBI := 1
@@ -42,49 +43,51 @@ endef
define Device/goflexnet
$(Device/dockstar)
- PROFILES := Generic GOFLEXNET
+ DEVICE_TITLE := Seagate GoFlexNet
DEVICE_DTS := kirkwood-goflexnet
endef
define Device/goflexhome
$(Device/dockstar)
- PROFILES := Generic GOFLEXHOME
+ DEVICE_TITLE := Seagate GoFlexHome
DEVICE_DTS := kirkwood-goflexhome
endef
define Device/linksys-audi
+ DEVICE_TITLE := Linksys EA3500 (Audi)
+ DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
DEVICE_DTS := kirkwood-linksys-audi
KERNEL_SIZE := 2624k
FILESYSTEMS := squashfs
- PROFILES := Generic AUDI
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Device/linksys-viper
+ DEVICE_TITLE := Linksys E4200v2 / EA4500 (Viper)
+ DEVICE_PACKAGES := kmod-mwl8k swconfig wpad-mini
DEVICE_DTS := kirkwood-linksys-viper
KERNEL_SIZE := 2688k
FILESYSTEMS := squashfs
- PROFILES := Generic VIPER
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
endef
define Device/iconnect
$(Device/dockstar)
- PROFILES := Generic ICONNECT
+ DEVICE_TITLE := Iomega Iconnect
DEVICE_DTS := kirkwood-iconnect
endef
define Device/pogo_e02
$(Device/dockstar)
- PROFILES := Generic POGOE02
+ DEVICE_TITLE := Cloud Engines Pogoplug E02
DEVICE_DTS := kirkwood-pogo_e02
endef
define Device/ib62x0
$(Device/dockstar)
- PROFILES := Generic IB62X0
+ DEVICE_TITLE := RaidSonic ICY BOX IB-NAS62x0
DEVICE_DTS := kirkwood-ib62x0
endef
diff --git a/target/linux/kirkwood/profiles/00-default.mk b/target/linux/kirkwood/profiles/00-default.mk
new file mode 100644
index 0000000000..ab2658c9b4
--- /dev/null
+++ b/target/linux/kirkwood/profiles/00-default.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile
+ PACKAGES:=kmod-mwl8k swconfig wpad-mini
+ PRIORITY:=1
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/kirkwood/profiles/100-generic.mk b/target/linux/kirkwood/profiles/100-generic.mk
deleted file mode 100644
index 07371737b5..0000000000
--- a/target/linux/kirkwood/profiles/100-generic.mk
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic (default)
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-thermal-kirkwood \
- kmod-mwl8k swconfig wpad-mini
-endef
-
-define Profile/Generic/Description
- Package set compatible with most Marvell Kirkwood based boards.
-endef
-
-$(eval $(call Profile,Generic))
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
deleted file mode 100644
index 7ccef69aa8..0000000000
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ /dev/null
@@ -1,108 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DOCKSTAR
- NAME:=Seagate FreeAgent Dockstar
- PACKAGES:= \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/DOCKSTAR/Description
- Package set compatible with Seagate FreeAgent Dockstar board.
-endef
-
-$(eval $(call Profile,DOCKSTAR))
-
-define Profile/GOFLEXHOME
- NAME:=Seagate GoFlexHome
- PACKAGES:= \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-usb2 kmod-usb-storage \
- uboot-envtools
-endef
-
-define Profile/GOFLEXHOME/Description
- Package set compatible with Seagate GoFlexHome
-endef
-
-$(eval $(call Profile,GOFLEXHOME))
-
-define Profile/GOFLEXNET
- NAME:=Seagate GoFlexNet
- PACKAGES:= \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/GOFLEXNET/Description
- Package set compatible with Seagate GoFlexNet
-endef
-
-$(eval $(call Profile,GOFLEXNET))
-
-define Profile/IB62X0
- NAME:=RaidSonic ICY BOX IB-NAS62x0
- PACKAGES:= \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/IB62X0/Description
- Package set compatible with RaidSonic ICY BOX IB-NAS62x0 board.
-endef
-
-$(eval $(call Profile,IB62X0))
-
-define Profile/ICONNECT
- NAME:=Iomega Iconnect
- PACKAGES:= \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/ICONNECT/Description
- Package set compatible with Iomega Iconnect board.
-endef
-
-$(eval $(call Profile,ICONNECT))
-
-define Profile/IOMEGA_IX2_200
- NAME:=Iomega StorCenter ix2-200
- PACKAGES:= \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/IOMEGA_IX2_200/Description
- Package set compatible with Iomega StorCenter ix2-200 board.
-endef
-
-$(eval $(call Profile,IOMEGA_IX2_200))
-
-define Profile/NSA310S
- NAME:=ZyXEL NSA310S
- PACKAGES:= \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/NSA310S/Description
- Package set compatible with ZyXEL NSA310S board.
-endef
-
-$(eval $(call Profile,NSA310S))
-
-define Profile/POGOE02
- NAME:=Cloud Engines Pogoplug E02
- PACKAGES:= \
- kmod-usb2 kmod-usb-storage
-endef
-
-define Profile/POGOE02/Description
- Package set compatible with Cloud Engines Pogoplug E02 board.
-endef
-
-$(eval $(call Profile,POGOE02))
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
deleted file mode 100644
index 7983755142..0000000000
--- a/target/linux/kirkwood/profiles/115-router.mk
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/AUDI
- NAME:=Linksys EA3500 (Audi)
- PACKAGES:= \
- kmod-mwl8k kmod-usb2 kmod-usb-storage \
- swconfig wpad-mini
-endef
-
-define Profile/AUDI/Description
- Package set compatible with Linksys EA3500 board.
-endef
-
-$(eval $(call Profile,AUDI))
-
-define Profile/VIPER
- NAME:=Linksys E4200v2 / EA4500 (Viper)
- PACKAGES:= \
- kmod-mwl8k kmod-usb2 kmod-usb-storage \
- swconfig wpad-mini
-endef
-
-define Profile/VIPER/Description
- Package set compatible with Linksys E4200v2 and EA4500 boards.
-endef
-
-$(eval $(call Profile,VIPER))
diff --git a/target/linux/kirkwood/profiles/120-plug.mk b/target/linux/kirkwood/profiles/120-plug.mk
deleted file mode 100644
index 0512aff450..0000000000
--- a/target/linux/kirkwood/profiles/120-plug.mk
+++ /dev/null
@@ -1,64 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/SHEEVAPLUG
- NAME:=Globalscale Technologies SheevaPlug
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core
-endef
-
-define Profile/SHEEVAPLUG/Description
- Package set compatible with Globalscale Technologies SheevaPlug board.
-endef
-
-$(eval $(call Profile,SHEEVAPLUG))
-
-define Profile/SHEEVAPLUGSATA
- NAME:=Globalscale Technologies eSATA SheevaPlug
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata
-endef
-
-define Profile/SHEEVAPLUGSATA/Description
- Package set compatible with Globalscale Technologies eSATA SheevaPlug board.
-endef
-
-$(eval $(call Profile,SHEEVAPLUGSATA))
-
-define Profile/GuruplugServerPlus
- NAME:=Globalscale Technologies Guruplug Server Plus
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata \
- kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio \
- wpad-mini
-endef
-
-define Profile/GuruplugServerPlus/Description
- Package set compatible with Globalscale Technologies Guruplug Server Plus board.
-endef
-
-$(eval $(call Profile,GuruplugServerPlus))
-
-define Profile/Topkick1281P2
- NAME:=Univeral Scientific Industrial Co. Topkick-1281P2
- PACKAGES:= \
- kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
- kmod-i2c-core kmod-i2c-mv64xxx \
- kmod-ata-core kmod-ata-marvell-sata
-endef
-
-define Profile/Topkick1281P2/Description
- Package set compatible with Univeral Scientific Industrial Co. Topkick-1281P2 board.
-endef
-
-$(eval $(call Profile,Topkick1281P2))