aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-05-28 21:43:39 +0000
committerLuka Perkov <luka@openwrt.org>2014-05-28 21:43:39 +0000
commit4122af10f9567ffbd72b1a4ebdcd1f6c221f0bae (patch)
treeeaa9d8ba5b20847649e617910525ea2270777449 /target/linux/kirkwood/profiles
parent95c615262c6931dac4bd58f37d15db2907403dfb (diff)
downloadupstream-4122af10f9567ffbd72b1a4ebdcd1f6c221f0bae.tar.gz
upstream-4122af10f9567ffbd72b1a4ebdcd1f6c221f0bae.tar.bz2
upstream-4122af10f9567ffbd72b1a4ebdcd1f6c221f0bae.zip
kirkwood: add support for Linksys EA4500
Support is added only for kernel 3.14 - do not show it until the switch is made. Following uboot env changes are needed to make it work on stock uboot:
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/115-router.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/115-router.mk b/target/linux/kirkwood/profiles/115-router.mk
new file mode 100644
index 0000000000..89a5bd435a
--- /dev/null
+++ b/target/linux/kirkwood/profiles/115-router.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/EA4500
+ NAME:=Linksys EA4500
+ PACKAGES:= \
+ kmod-mwl8k kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/EA4500/Description
+ Package set compatible with Linksys EA4500 board.
+endef
+
+EA4500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+EA4500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+# $(eval $(call Profile,EA4500))