aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/kirkwood/profiles
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2014-02-16 00:14:27 +0000
committerLuka Perkov <luka@openwrt.org>2014-02-16 00:14:27 +0000
commit2d49e9d8ace437c4e88b5f6b032f6c902da2dd4e (patch)
tree1b3a9bbc6eaaef964f5f5de26b355af63c36beb5 /target/linux/kirkwood/profiles
parent55db723f0b5e2afb3fd65867818a6537c8268158 (diff)
downloadupstream-2d49e9d8ace437c4e88b5f6b032f6c902da2dd4e.tar.gz
upstream-2d49e9d8ace437c4e88b5f6b032f6c902da2dd4e.tar.bz2
upstream-2d49e9d8ace437c4e88b5f6b032f6c902da2dd4e.zip
kirkwood: add support for Seagate GoFlexNet
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39595 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/profiles')
-rw-r--r--target/linux/kirkwood/profiles/110-nas.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/kirkwood/profiles/110-nas.mk b/target/linux/kirkwood/profiles/110-nas.mk
index 6605f69362..bcd7555b44 100644
--- a/target/linux/kirkwood/profiles/110-nas.mk
+++ b/target/linux/kirkwood/profiles/110-nas.mk
@@ -22,6 +22,23 @@ DOCKSTAR_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
$(eval $(call Profile,DOCKSTAR))
+define Profile/GOFLEXNET
+ NAME:=Seagate GoFlexNet
+ PACKAGES:= \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+ uboot-envtools
+endef
+
+define Profile/GOFLEXNET/Description
+ Package set compatible with Seagate GoFlexNet
+endef
+
+GOFLEXNET_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+GOFLEXNET_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,GOFLEXNET))
+
define Profile/IB62X0
NAME:=RaidSonic ICY BOX IB-NAS62x0
PACKAGES:= \